How do I intergrate APs into a campus network without Vlan 1

Unanswered Question
Oct 26th, 2008
User Badges:
  • Silver, 250 points or more

All cisco LAN documentation talks about NOT using vlan 1 as the native vlan, this is ok on switches but how do I do this on APs? You cannot delete BVI1, I have multiple voice ,data and Wireless vlans

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lamav Sun, 10/26/2008 - 18:54
User Badges:
  • Blue, 1500 points or more

Why do you feel that you have to use vlan 1 as the native vlan?


You can configure any vlan to be the native vlan in an AP.


I am presently working in a configuration in which I have a 1242 AP connected to a switchport on a 3750 that is configured as a trunk. The AP supports 3 SSIDs (3 vlans) and they are configured as sub interfaces on the fastethernet interface of the AP (like a router on a stick). One of those vlans happens to be the native vlan...


The BVI interface is your management interface and it can reside in the native vlan if you wish.


Does this help or am I misunderstanding your question?

Richard Bradfield Sun, 10/26/2008 - 20:47
User Badges:
  • Silver, 250 points or more

I dont want to use Vlan1 for the switches( as per Cisco recommendations ) looking at it i can configure the APS something like ;-

interface Dot11Radio0.1

encapsulation dot1Q 51

!

interface FastEthernet0.1

encapsulation dot1Q 51

!

interface BVI1

ip address 192.168.111.103 255.255.255.0


then I still use BVI1 for the management of the AP but it is no longer on vlan 1

andrew.butterworth Mon, 10/27/2008 - 03:07
User Badges:
  • Gold, 750 points or more

Since the AP's are not switches you also need the Bridge-Group commands to link the SSID's to the FastEthernet Sub-Interfaces. The Bridge-Group ID is also used to tie the Management interface to so it doesn't have to be VLAN 1:


interface FastEthernet0.50

encapsulation dot1Q 50 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 192.168.130.29 255.255.255.224

no ip route-cache

!



HTH


Andy

lamav Mon, 10/27/2008 - 15:16
User Badges:
  • Blue, 1500 points or more

Andy:


Interesting...


Can you elaborate further?


how does one make the determintion that bridging is necessary? Can you elaborate a bit more on bridging, etc?


Thanks


Victor

Richard Bradfield Mon, 10/27/2008 - 16:16
User Badges:
  • Silver, 250 points or more

Victor,

THe wireless APs are not routers, so the only way to link the wired Fast ethernet interface to the radio interfaces is by bridging, this applies to the vlans eg:

int fa0.1

bridge-group 1

int fa0.50

bridge-group 2

int fa0.51

bridge-group 3

int dot11radio0.1

bridge-group 1

int dot11radio0.50

bridge-group 2

int dot11radio0.51

bridge-group 3


so in above example the vlans on the wired side ae matched to the radio subnets


Actions

This Discussion