CUCM 5.1 Upgrade failure_ from 5.1.1.3122-1 to 6.1.2.1000-13

Unanswered Question
Oct 27th, 2008
User Badges:

While upgrading CUCM (publisher) from 5.1.1 to 6.1.2, we got a message saying that the upgrade is not allowed. Is there any known reason for that?

A part of the output we got during the upgrade process is presented in the following :


------------------------------------------

10/25/2008 11:38:37 upgrade_install.sh|Unzip file /common/download/cisco-ipt-k9-patch6.1.2.1000-13.tar.gz|<LVL::Info>

10/25/2008 11:40:51 upgrade_install.sh|Unzip complete|<LVL::Info>

10/25/2008 11:40:51 upgrade_install.sh|Untar file /common/download/cisco-ipt-k9-patch6.1.2.1000-13.tar|<LVL::Info>

10/25/2008 11:45:20 upgrade_install.sh|Untar complete|<LVL::Info>

10/25/2008 11:45:20 upgrade_install.sh|-rwxrwxrwx 1 900711 named 3641 Apr 28 23:00 /common/download/6.1.2.1000-13/base_scripts/AppInstall|<LVL::Debug>

10/25/2008 11:45:20 upgrade_install.sh|Start AppInstall|<LVL::Info>

10/25/2008 11:45:20 upgrade_install.sh|sudo /common/download/6.1.2.1000-13/base_scripts/AppInstall -2 --taos-basepath /common/download/6.1.2.1000-13/ --taos-logfile /var/log/install/install_log_081025113823.log --taos-resultfile /var/log/install/upgrade-results.xml|<LVL::Debug>

10/25/2008 11:45:20 AppInstall|/common/download/6.1.2.1000-13//Cisco/base_scripts/upgrade_manager.sh type=upgrade basepath=/common/download/6.1.2.1000-13/ resultfile=/var/log/install/upgrade-results.xml |<LVL::Debug>

10/25/2008 11:45:21 upgrade_manager.sh|Upgrade from 5.1.1.3122-1 not allowed|<LVL::Error>

10/25/2008 11:45:21 upgrade_install.sh|Cleaning up download...|<LVL::Info>

10/25/2008 11:45:21 upgrade_install.sh|Removing /common/download/cisco-ipt-k9-patch6.1.2.1000-13.*|<LVL::Info>

10/25/2008 11:45:21 upgrade_install.sh|Removing /common/download/6.1.2.1000-13|<LVL::Info>

10/25/2008 11:45:21 upgrade_install.sh|Cleaning up misc...|<LVL::Info>

10/25/2008 11:45:46 upgrade_install.sh|Dumping /usr disk usage to /usr/local/platform/conf/usr_du_out.txt|<LVL::Info>

10/25/2008 11:45:49 upgrade_install.sh|Cleaning up rpm_archive...|<LVL::Info>

10/25/2008 11:45:49 upgrade_install.sh|Removing /common/rpm-archive/6.1.2.1000-13|<LVL::Info>

10/25/2008 11:45:49 upgrade_install.sh|CSA Status = 0|<LVL::Debug>

10/25/2008 11:45:49 upgrade_install.sh|/etc/init.d/ciscosec start|<LVL::Info>

----------------------------------------------

thanks in adavance.

best regards,






  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Rob Huffman Mon, 10/27/2008 - 07:08
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Ramzi,


This upgrade *** will require you to order the Media Kits and License via PUT. It looks like you are trying the downlaod file;


Upgrade Paths To Cisco Unified Communications Manager 6.1(2)


You can upgrade directly to Cisco Unified Communications Manager 6.1(2) from:


•4.2(3x)


•5.1(2x)


•5.1(3x)


•6.0(1a)


•6.1(1x)




--------------------------------------------------------------------------------


Caution: Use the ISO files that are mentioned in the "Upgrading from Cisco Unified Communications Manager Release 6.0.(1a) or higher to Release 6.1(2) by Using the UCSInstall File" section for upgrades from 6.1(1x)only.


--------------------------------------------------------------------------------


Upgrading from Unified CM 4.x and 5.x


***If you are upgrading from 4.1.3, 4.2.3, 5.1.1, 5.1.2, or 5.1.3, use the Product Upgrade Tool (PUT) or the PUT that is for registered customers only to obtain a media kit and license or to purchase the upgrade from Cisco Sales.


To use the PUT, youmust enter your Cisco contract number (Smartnet, SASU or ESW) and request the CD/CD set. If you do not have a contract for Cisco Unified Communications Manager, you must purchase the upgrade from Cisco Sales.


For more information about supported Unified CM upgrades, see the Cisco Unified Communications Manager Compatibility Matrix at the following URL:


http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_device_support_tables_list.html


From these good release notes;


http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/rel_notes/6_1_2/cucm-rel_note-612.html#wp396032


Hope this helps!

Rob


tka@tn.ibm.com Tue, 10/28/2008 - 07:22
User Badges:

Thanks Rob for your response,

However I have ordered the upgrade pak properly using the PUT tool.

Thus, the problem is still there.

regards,

Jaime Valencia Tue, 10/28/2008 - 08:41
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

actually there is no problem, you're trying to do an upgrade that is not supported and that's why you're getting the error which is working as designed.


you ALWAYS need to look at compatibility matrix in order to plan upgrades and order the right SW


Table 4 Supported Cisco Unified Communications Manager Upgrades for Release 6.x and Release 7.x

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/ccmcompmatr.html#wp40122


there is no upgrade from 5.1(1) to 6.1(2), you need to run any of these versions for this to work:


6.1(1), 6.0(1b), 6.0(1a), 6.0(1), 5.1(3), 5.1(2)


i'm afraid you'll have to do this in two phases


HTH


java


if this helps, please rate

Rob Huffman Tue, 10/28/2008 - 08:52
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications


Nice catch Java! I wasn't reading that too well was I :) +5 points for your great work.


Cheers!

Rob

Actions

This Discussion