Cisco 2811 - turn off dhcp client

Unanswered Question
Oct 27th, 2008
User Badges:

Hello guys,


I have a Cisco 2811 router that is sending out DHCP discovery packets.

The only dhcp related line in the config is the 'no dhcp service' command, there is no dhcp command under any interface command.


Do you know how can I turn off this ?



router2811#debug dhcp detail

Oct 27 09:57:36.198 EDT: DHCP: DHCP client process started: 10

Oct 27 09:57:36.198 EDT: DHCP: proxy allocate request

Oct 27 09:57:36.198 EDT: DHCP: new entry. add to queue, interface

Oct 27 09:57:36.198 EDT: DHCP: SDiscover attempt # 1 for entry:

Oct 27 09:57:36.198 EDT: Temp IP addr: 0.0.0.0 for peer on Interface: unknown

Oct 27 09:57:36.198 EDT: Temp sub net mask: 0.0.0.0

Oct 27 09:57:36.198 EDT: DHCP Lease server: 0.0.0.0, state: 1 Selecting

Oct 27 09:57:36.198 EDT: DHCP transaction id: 16B9

Oct 27 09:57:36.198 EDT: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs

Oct 27 09:57:36.198 EDT: Next timer fires after: 00:00:04

Oct 27 09:57:36.198 EDT: Retry count: 1 Client-ID: saa-23679,80444

Oct 27 09:57:36.198 EDT: Client-ID hex dump: 73blablalbla33637392C3830343434

Oct 27 09:57:36.198 EDT: Hostname: router2811

Oct 27 09:57:36.198 EDT: DHCP: SDiscover: sending 283 byte length DHCP packet

Oct 27 09:57:36.198 EDT: DHCP: SDiscover 283 bytes

Oct 27 09:57:36.198 EDT: B'cast on FastEthernet0/0.351 interface from 10.0.168.10

Oct 27 09:57:36.198 EDT: B'cast on FastEthernet0/0.352 interface from 10.0.160.10




router2811#sh runn | include dhcp

no service dhcp

router2811#



Thanks,

Daniel

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
John Blakley Mon, 10/27/2008 - 12:11
User Badges:
  • Purple, 4500 points or more

Are you using a helper command on interface 0.351 and 0.352?


--John

daniell_longhi Tue, 10/28/2008 - 03:56
User Badges:

Hi John,


No, I'm not using ip helper.


These are the configs of the interfaces:



interface FastEthernet0/0.351

description subnet10.0.168.0/21-vlan351

encapsulation dot1Q 351 native

ip address 10.0.168.10 255.255.248.0

ip access-group xyz in

no ip redirects

no ip unreachables

no ip proxy-arp

no snmp trap link-status

arp timeout 420

service-policy output xyz_voip

end


*


interface FastEthernet0/0.352

description subnet10.0.160.0/25-vlan352

encapsulation dot1Q 352

ip address 10.0.160.10 255.255.255.128

ip access-group xyz in

no ip redirects

no ip unreachables

no ip proxy-arp

no snmp trap link-status

arp timeout 420

service-policy output xyz_voip

end



Thanks,


Daniel

John Blakley Tue, 10/28/2008 - 06:34
User Badges:
  • Purple, 4500 points or more

If you have no need for any dhcp, you could run no ip bootp server and see if that helps. It's a global command.


--John

Richard Burts Tue, 10/28/2008 - 09:01
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Daniel


are any of the interfaces configured with ip address negotiated? This would initiate DHCP.


Perhaps it would be helpful if you would post the confiuration of all of the interfaces?


HTH


Rick

daniell_longhi Tue, 10/28/2008 - 10:18
User Badges:

John,

The 'no ip bootp server' was already there.



Rick,

the 2 subinterfaces are configured with static ip addresses and the interface Fast0/0 has the 'no ip address' command. There is no interface configured to obtain the ip in negotiation mode.



A friend of mine suggested to add and remove an 'ip address x y' on the Fast0/0 interface to kinda refresh it, I just did that but it didn't not work.



Thanks,

Daniel

John Blakley Tue, 10/28/2008 - 10:25
User Badges:
  • Purple, 4500 points or more

Daniel,


At this point it might benefit you more if you could post your config.


Thanks,


John

daniell_longhi Mon, 11/03/2008 - 08:47
User Badges:

I got it:



debug ip sla trace

Nov 1 14:03:36.754 EDT: IP SLAs(23679) dhcp operation: Starting dhcp operation

Nov 1 14:03:37.394 EDT: IP SLAs(23679) dhcp operation: request gave address 10.2.173.14 255.255.248.0 in 639 ms

Nov 1 14:04:36.756 EDT: IP SLAs(23679) dhcp operation: Starting dhcp operation

Nov 1 14:04:37.396 EDT: IP SLAs(23679) dhcp operation: request gave address 10.2.173.14 255.255.248.0 in 639 ms

Nov 1 14:05:36.758 EDT: IP SLAs(23679) dhcp operation: Starting dhcp operation

Nov 1 14:05:37.398 EDT: IP SLAs(23679) dhcp operation: request gave address 10.2.173.14 255.255.248.0 in 639 ms



Thank you all.


Daniel

Richard Burts Mon, 11/03/2008 - 10:04
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Daniel


I am glad that you figured it out. IP SLA is a pretty obscure thing to initiate DHCP. Thank you for posting back to the thread indicating that you had solved it and what the solution was. It helps make the forum more useful when people can read about a problem and can read the solution to the problem.


HTH


Rick

Actions

This Discussion