7942s and CME stopped working after update to CME 7.0/4.3

Unanswered Question
Oct 27th, 2008


I had a CME system on CME 4.1 with 7942s working just fine with 12.4(15)T4 IOS Adv IP Services and upgraded to 12.4(15)XZ1 and 12.4(20)T1 (tried both) to get support for the 7937 model phone.

But when I went to the new IOS, the 7942s would not register. It was kind of funny because out of 10, 1 registered for a few minutes briefly (I could make calls) but the rest just sat there saying registering on the display. Then after about 10 mins, the display would just go blank with lines on it. And after a few minutes the phone that was registered started doing the same thing.

All the config looked good, same as before, and the 7942 phones did upgrade to the 8.3.3S phoneload fine. I went back to 12.4(15)T4 IOS and all the phones registered and worked fine without issue, on the 8.3.3S phone load even. But when I changed IOS back to 12.4(20)T1 again, the 7942s had same problem.

Any changes between CME 4.1 and 4.3/7.0 that would cause phones not to register or register briefly then unregister?

I had done a create cnf under telephony service, and removed a few ephone's and put them back from scratch and same problem.

I did a debug ephone register, and this is what it is saying, but the system is set to non-secure mode under the ephones and telephony-service.

Oct 27 19:08:44.219: New Skinny socket accepted [2] (3 active)

Oct 27 19:08:44.219: sin_family 2, sin_port 17295, in_addr

Oct 27 19:08:44.219: skinny_add_socket 2 17295

Oct 27 19:08:44.219: New Skinny socket accepted [2] (4 active)

Oct 27 19:08:44.219: sin_family 2, sin_port 41825, in_addr

Oct 27 19:08:44.219: skinny_socket_process: Can not establish secure session for socket 2

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Kenneth Mohammed Mon, 10/27/2008 - 19:10


Did you try to do a factory reset on one of the 7942's to see if that resolves the issue?

Erick Bergquist Mon, 10/27/2008 - 20:19

Yep, no change with factory reset on new IOS. But they came right up when changed back to old IOS.

Oct 27 19:06:02.895: %IPPHONE-6-REGISTER: ephone-4:SEP002290BB7D54 IP: Socket:1 DeviceType:Phone has registered.

Oct 27 19:07:32.611: %IPPHONE-6-UNREGISTER_ABNORMAL: ephone-4:SEP002290BB7D54 IP: Socket:1 DeviceType:Phone has unregistered abnormally.

Erick Bergquist Sat, 11/08/2008 - 15:14

BTW, I got this working by adding the command "secure-signaling trustpoint test" under telephony-services on the new IOS even though the phones were set up in non-secure mode.

Doesn't make sense why that was needed.

Once that was in there, all the phones, and the local analog ports set up as SCCP all registered fine and remain up and working.

I took it out, rebooted and same problem until the command was put back. I've been combing through the cisco docs and so far nothing really is adding up as to why a secure-signaling trustpoint needs to be configured when the default is none. TAC is stumped to.


This Discussion