LMS Email Notification Group Issue .

Unanswered Question
Oct 27th, 2008
User Badges:

Hi ,


We are using the LMS 3.1 . Here we have around 20 numbers of Notification and Email notification group .Recently we have got a complaint like some users ( or IDs) in a particular email group not receiving mails .


So we have checked SMTP server and created a new notification group and included this IDs there in the new notification gorup .But that ids are receiving mails in this group .

Can any one tell me the way for tracing this email triggering is happeing or not with ids in LMS .


Regards ,

Snjish.K




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Mon, 10/27/2008 - 23:35
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Enable Notification Services debugging under DFM > Configuration > Other Configurations > Logging. Once an event or alert is generated which should match a configured email notification subscription, check the NMSROOT/log/dfmLogs/NOS/nos.log to see if the emails were sent correctly.

k_sinjish Tue, 10/28/2008 - 01:28
User Badges:

Hi ,


Thanks for the swift respose .


1.Will the entry comes here only for failure ?

2. Can you plese decode what is the reason of the below given error .


Thread:1|EpmDataQueueItem|processEPMData()|.|Could not retrieve alert for moid = 128

08-Aug-2008|12:40:21.097|ERROR|NOS|Email Notify Thread:Pooled Thread:1|EmailUtility|createAndSendMail()|.|

Mail was not sent to ; [email protected]

08-Aug-2008|12:40:22.316|ERROR|NOS|Email Notify Thread:Pooled Thread:1|EmailUtility|createAndSendMail()|.|

Mail was not sent to ; [email protected]

08-Aug-2008|12:40:23.206|ERROR|NOS|Email Notify Thread:Pooled Thread:1|EmailUtility|createAndSendMail()|.|

Mail was not sent to ; [email protected]

08-Aug-2008|12:40:51.004|ERROR|NOS|Email Notify Thread:Pooled


Regards ,

sinjish.K


Joe Clarke Tue, 10/28/2008 - 07:40
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This indicates a communications problem between DFM and your SMTP server. The only way to troubleshoot this further is to get a sniffer trace of TCP port 25 traffic to the SMTP server when DFM fires off an email notification.

k_sinjish Tue, 11/04/2008 - 22:38
User Badges:

Hi ,


We have monitored the traffic in between the LMS and the SMTP server .


We have created a notification , e mail notification group and moved certain mail ids

and one router to that group .


Then we applied


no snmp-server community fox0skat RO

no snmp-server community fox0skat1 RW


But we did no see any any traffic is generated with protocol SMTP


In the notification services event set we configured the below given events


1.Unresponsive

2.StateNotNormal

3.RepeatedRestarts

4.OutOfRange

5.OperationallyDown

6.InsufficientFreeMemory

7.HighQueueDropRate

8. HighDiscardRate

9. HighCollisionRate

10. HighBufferUtilization

11. HighBroadcastRate

12. Flapping



So


1. will it trigger mail when we remove the above given SNMP commands


2. How LMs gets info from the equipments

( by SNMP or ICMP)



3. In this situation ( no SMTP traffic ) how do I proceed .




Regards ,

Sinjish.k



Joe Clarke Wed, 11/05/2008 - 09:54
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Assuming that you completely disabled SNMP for one DFM polling cycle, you should have received an event in your Alerts and Activities Display. If so, then you should have seen a notification go out. Typically, when I troubleshoot such problems, I check the nos.log in parallel with the sniffer trace so I can correlate what's going on. It's not clear from your description that adequate testing was done.


You might consider opening a TAC service request so that this problem can be analyzed in real time.

Actions

This Discussion