BGP ORF

Answered Question
Oct 28th, 2008

Hi Guys,

Just going over some BGP ORF and i am a little confused.

See this config...

AS100_PE#

router bgp 100

neighbor 10.0.0.200 remote-as 200

!

address-family ipv4

neighbor 10.0.0.200 capability orf prefix-list receive

neighbor 10.0.0.200 activate

exit-address-family

AS200_CE#

router bgp 200

neighbor 10.0.0.100 remote-as 100

!

address-family ipv4

neighbor 10.0.0.100 capability orf prefix-list send

neighbor 10.0.0.100 prefix-list AS_100_INBOUND in

exit-address-family

What is the acivate keyword for? I have ORF working wihtout it!

Thanks

Stephen

Correct Answer by marikakis about 8 years 3 months ago

Hello,

Whether the "neighbor activate" for the ipv4 address-family is needed or not,

depends on the status of the "no bgp default ipv4-activate".

If "no bgp default ipv4-activate" is in effect, you need to "activate" a new ipv4 session.

This would depend on your IOS defaults.

Please have a look at the following documentation:

http://www.cisco.com/en/US/docs/ios/12_3/switch/command/reference/swi_n1.html#wp1033953

The following is stated there:

"The exchange of addresses with BGP neighbors is enabled for the IPv4 address family. Enabling address exchange for all other address families is disabled."

"Address exchange for address family IPv4 is enabled by default for each BGP routing session configured with the neighbor remote-as command

unless you configure the no bgp default ipv4-activate command

before configuring the neighbor remote-as command, or

you disable address exchange for address family IPv4 with a specific neighbor

by using the no form of the neighbor activate command."

I am not sure if the same defaults apply to all versions. In any case, it's best to lookup commands in the documentation for your specific IOS versions.

Kind Regards,

M.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
marikakis Wed, 10/29/2008 - 03:19

Hello,

Whether the "neighbor activate" for the ipv4 address-family is needed or not,

depends on the status of the "no bgp default ipv4-activate".

If "no bgp default ipv4-activate" is in effect, you need to "activate" a new ipv4 session.

This would depend on your IOS defaults.

Please have a look at the following documentation:

http://www.cisco.com/en/US/docs/ios/12_3/switch/command/reference/swi_n1.html#wp1033953

The following is stated there:

"The exchange of addresses with BGP neighbors is enabled for the IPv4 address family. Enabling address exchange for all other address families is disabled."

"Address exchange for address family IPv4 is enabled by default for each BGP routing session configured with the neighbor remote-as command

unless you configure the no bgp default ipv4-activate command

before configuring the neighbor remote-as command, or

you disable address exchange for address family IPv4 with a specific neighbor

by using the no form of the neighbor activate command."

I am not sure if the same defaults apply to all versions. In any case, it's best to lookup commands in the documentation for your specific IOS versions.

Kind Regards,

M.

stephen.stack Wed, 10/29/2008 - 03:52

That makes sense. So it's no an ORF isseu then. It seems to be a conincidence that this config was on the lab i am configuring. Thanks for the info. It helped a lot.

Stephen

Actions

This Discussion