×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

IOS CLI for WPA2 needed..

Unanswered Question
Oct 28th, 2008
User Badges:

Hi,


I can't get my 871w to enable WPA2 for it. I found a reference to "wpa version 2" as CLI which my rather new IOS doesn't seem to understand.

So how to enable WPA2 via CLI commands? And by the way do you have a link to the wireless CLI reference?


Ciao, Bernd

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jeff.kish Thu, 10/30/2008 - 06:26
User Badges:
  • Silver, 250 points or more

I seem to remember that the 871 series does not support AES. I last touched one of these well over 6 months ago, and I remember being surprised that it didn't support it. Without AES, there's no way to configure WPA2.


To find out, enter the following:


int Dot11Radio0

encryption mode ciphers ?


If it lists aes, you're good. If not, you'll need to use WPA and TKIP, which is still a good solution.

berndkunrath Thu, 10/30/2008 - 11:04
User Badges:

Hi Jeff,


thanks for message and the help - I appreciate that!


Yes my router shows the option:


CiscoKunr(config)#int Dot11Radio 0

CiscoKunr(config-if)#encryption mode ciphers ?

aes-ccm WPA AES CCMP

tkip WPA Temporal Key encryption

wep128 128 bit key

wep40 40 bit key


And I set it to aes-ccm, but my client (Macbook) says it's still WPA and not WPA2 like my D-Link wireless. Is the message of the Mac OSX wrong or do I miss something else in the setting for WPA2?


Ciao, Bernd

berndkunrath Thu, 10/30/2008 - 14:54
User Badges:

Hi Jeff,


it's me again. I checked the WLAN again with a Windwos cleitn and yes - now with the setting aes-ccm its shown as WPA2!


Thanks again!

jeff.kish Fri, 10/31/2008 - 05:50
User Badges:
  • Silver, 250 points or more

Great, glad to hear it! Now I'm second-guessing myself, I think it was an 1841 wireless module that didn't support AES.

Actions

This Discussion