EoMPLS issue

Unanswered Question
Oct 28th, 2008
User Badges:

Hi all,


I have seen a few questions posted on the forum about EoMPLS issues, but the one I have is different to those already posted and responded too.


I have attached a document which includes the topology, configurations and output from commands to show the problem.

Basically between the two PE routers concerned with the EoMPLS tunnel, I'm receiving labels for the VC from the egress PE, as well as the next hop label. However, the VC will not become active and the next-hop address (shown in one of the outputs) is stating it is an invalid address.


Any ideas?


Thanks



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
mazlan.alatif Tue, 10/28/2008 - 21:53
User Badges:

Hi,


Hv you check your vlan 69 interface? Is it UP?


Thanks,


--mazlan

obrien.steve Tue, 10/28/2008 - 22:26
User Badges:

At both PE routers this VLAN is up and the label has been assigned to the VC. If I shut down the VLAN, then the label assigned to the VC is removed from the remote PE. It all looks OK from a LDP label distribution perspective, but I'm not sure on why the next hop is invalid. Outputs I have seen from examples of the command "show mlps l2tunnel vc detail" states the next hop as point2point. If i view the routing table and mpls forwarding table, I can see that the next hop address is there and assigned a label.

mazlan.alatif Tue, 10/28/2008 - 23:01
User Badges:

Can you ping mpls from PE2 to PE3?

I hv similar problem last time, but it was due to MTU issue. Seems your MTU is OK.

obrien.steve Wed, 10/29/2008 - 00:15
User Badges:

I can ping all loopback addresses of all PE routers if that is what you mean. I also have a L3VPN running across the environment from the same CE routers and the routes are received fine from the remote CE.


Thanks

Steve

jim.reynolds Wed, 10/29/2008 - 07:30
User Badges:

You haven't provided enough information to fully debug this.

You will have to provide the following

MPLS forwarding-table for each node

'sh ip cef' - Do this for PEs managing the L2Transport

'sh ip ro'


I think you have to configure a targeted LDP neighbor in each PE i.e.

mpls ldp neighbor 10.248.255.223 targeted ldp

and

mpls ldp neighbor 10.248.255.228 targeted ldp


If that doesn't work then post the output of the commands

Harold Ritter Wed, 10/29/2008 - 08:44
User Badges:
  • Cisco Employee,

Steve,


The xconnect is configured under the SVI. This is referred to software based EoMPLS and requires a SIP or ES card for the core facing interface.


You need to configure the xconnect under the physical interface (or subinterface) to switch to sup based EoMPLS, which will alleviate the need for a SIP or ES card.


Regards

obrien.steve Wed, 10/29/2008 - 14:59
User Badges:

Harold,


Many thanks with your reply. Changing it from a VLAN-based EoMPLS configuration to a Port-Based EoMPLS configuration brought the VC up.

I was hoping on using VLAN based so I could try to do VLAN re-writing on the 6509. But not being classed as a router, I wasn't sure if this would even be possible anyway. Any suggestions on the best way to renumber the VLAN over an MPLS network? I'm work for the enterprise and this is a self managed MPLS network so either way the re-mapping of VLANs falls into my basket if we have to do it outside the MPLS network. It is just alot cleaner with MPLS...


Regards

Steve

Actions

This Discussion