ACE4710 Tcp Probe FIN ACK delay

Unanswered Question
Oct 29th, 2008
User Badges:

Is it possible to influence on a delay between ACE sending FIN for tcp probe and expecting FIN-ACK from real server (default 1 second). Customer don't want to use RST Sometimes happens that server is not responding in time.


Thanks in advance.


Regards,

Branko Mlakar

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Gilles Dufour Tue, 11/04/2008 - 06:17
User Badges:
  • Cisco Employee,

ACE will wait up to receive timeout (default 10 sec) for the FIN/ACK


Below is an example from my lab where I force my server to wait 5sec before sending the fin/ack


79.991989 192.168.30.121 -> 10.10.10.10 TCP 12861 > 5000 [SYN] Seq=0 Ack=0 Win=5840 Len=0 MSS=1412 TSV=68409833 TSER=0 WS=0

79.993518 10.10.10.10 -> 192.168.30.121 TCP 5000 > 12861 [SYN, ACK] Seq=0 Ack=1 Win=8192 Len=0

79.993709 192.168.30.121 -> 10.10.10.10 TCP 12861 > 5000 [ACK] Seq=1 Ack=1 Win=5840 Len=0

79.993815 192.168.30.121 -> 10.10.10.10 TCP 12861 > 5000 [FIN, ACK] Seq=1 Ack=1 Win=5840 Len=0

84.994405 10.10.10.10 -> 192.168.30.121 TCP 5000 > 12861 [FIN, ACK] Seq=1 Ack=2 Win=8192 Len=0

84.994592 192.168.30.121 -> 10.10.10.10 TCP 12861 > 5000 [ACK] Seq=2 Ack=2 Win=5840 Len=0


You should maybe sniff the traffic to verify what is the exact problem.


Also, run A2(1.2) due to this bug fix :

CSCsr04062: TCP probe fails if rserver sends FIN after 3-way handshake


Gilles.

bmlakar Tue, 11/04/2008 - 07:36
User Badges:

Hi Gilles,


first thank for reply.


Here are config for probes:


probe icmp ICMP ICMP probe - there are no problems!

interval 5

faildetect 4

passdetect interval 15

passdetect count 4

probe tcp T-CTS1 TCP probe - FIN problems from time to time!

port 20008

interval 15

faildetect 4

passdetect interval 60

passdetect count 5

open 2


From capture file it is seen that ACE4710 sends RST after 1 second after tcp session established. This is probably server problem (customer has already opened a case) but it might be a solution with ace to extend this delay. From your description you have 10 second delay. It should have something with probe value set?


I'm attaching part of capture file.


Regards,

Branko



Attachment: 
Gilles Dufour Tue, 11/04/2008 - 08:30
User Badges:
  • Cisco Employee,

What version do you run ?

I believe this was fixed in A2(1.2) at the same time as the bug I sent you.


Gilles.

bmlakar Fri, 11/07/2008 - 03:29
User Badges:

Customer is running version c4710ace-mz.A3_2_0.bin .


Branko

bmlakar Mon, 11/10/2008 - 08:56
User Badges:

Thanks for update Gilles.


As seen from bug description this is not our case. As you mentioned in your test lab delay was 10 second and we experience 1 second delay.

Is this is going be corrected in version 3(2.1)?


Regards,

Branko

Gilles Dufour Tue, 11/11/2008 - 04:10
User Badges:
  • Cisco Employee,

I tested 3(2.0) and I don't see the problem either.




9.998886 192.168.30.10 -> 10.10.10.10 TCP 51207 > 5000 [SYN] Seq=0 Ack=0 Win=5840 Len=0 MSS=1460 TSV=4294829423 TSER=0 WS=2

10.000088 10.10.10.10 -> 192.168.30.10 TCP 5000 > 51207 [SYN, ACK] Seq=0 Ack=1 Win=8192 Len=0

10.000295 192.168.30.10 -> 10.10.10.10 TCP 51207 > 5000 [ACK] Seq=1 Ack=1 Win=5840 Len=0

10.000334 192.168.30.10 -> 10.10.10.10 TCP 51207 > 5000 [FIN, ACK] Seq=1 Ack=1 Win=5840 Len=0

10.000578 10.10.10.10 -> 192.168.30.10 TCP 5000 > 51207 [ACK] Seq=1 Ack=2 Win=8192 Len=0

15.006926 10.10.10.10 -> 192.168.30.10 TCP 5000 > 51207 [FIN, ACK] Seq=1 Ack=2 Win=8192 Len=0

15.007125 192.168.30.10 -> 10.10.10.10 TCP 51207 > 5000 [ACK] Seq=2 Ack=2 Win=5840 Len=0

Actions

This Discussion