high CPU utilization!!

Unanswered Question
Oct 29th, 2008

I have two cisco routers connected via leased line ,suddenly the cpu utilization became 99.9% ,the show processes cpu gives high utilization for "encrypt proc" process???what this means???!!!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
mohammady Wed, 10/29/2008 - 22:56

when I disable the VPN between the two routers the cpu usage return back to normal situation ???any help??!

r.sneekes Thu, 10/30/2008 - 03:43

It seems your router is recieving a lot of traffic that needs te be encrypted but it seems the router can't handle the load.

Does the router has an hardware vpn accelator? If not Encryption is handled by the router CPU.

Maybe try to reduce the traffic that needs to be encrypted.

mohammady Thu, 10/30/2008 - 03:51

the router was working properly without any problem ,traffic load is the same from a long time ,,,,,,no increase in traffic load

pkaretnikov Thu, 10/30/2008 - 19:45

What model router, what IOS version, how much traffic?

Have you tried updating the IOS? It could be a bug.

mohammady Fri, 10/31/2008 - 06:42

router model =2600

IOS version =


traffic on the lease linenot more than 30%

is66rlhntadm Fri, 10/31/2008 - 07:07

If you can find one then a "AIM-vpn/epII" would help by offloading the encryption

(someone please correct me if I'm wrong I know that the aim-vpn/ep works on a 2651 but I'm unsure about the II)

it maybe possible something on the other side of the tunnle has changed

mohammady Fri, 10/31/2008 - 13:03

for sure the problem is not on the traffic load ,traffic didnt exceed 30% on the lease line..suddenly the cpu utilization become 99% the process utilizing the cpu is "encrypt proc"

any other suggestion??

thanks for all replies.....

phcardoni Tue, 11/11/2008 - 10:27

When you stop to use encrypt something happen? A proccess go down? Infact, when the proccess grow up? when you start some proccess in a router, like dhcp, nat, etc...?


This Discussion