2511 Terminal server setup

Unanswered Question
Oct 29th, 2008

I'm trying to setup a 2511 as a terminal server. I've connected the ethernet port to the console port of the device I need remote access to. Followed all the steps on this page http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a008014f8e7.shtml#cs

I've given the loopback a non routable IP (172.22.2.1) and used the same to define my IP host

ip host router 2008 172.22.2.1

but when I telnet from the 2511 using the command telnet 172.22.2.1 2008 it telnets to the 2511 itself and hangs!!! what am I doing wrong? Do I need to do anything on the device that I want to have remote access to?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Richard Burts Wed, 10/29/2008 - 13:19

Uzma

There is not anything that you would need to do on the device that you want remote access to. But I think the main problem is shown in your statement that "I've connected the ethernet port to the console port of the device I need remote access to". You should connect one of the cable of the async interface on the 2511 and not its Ethernet to the console port of the other device.

HTH

Rick

uzmausmani Wed, 10/29/2008 - 14:11

No I must have mistyped it. My ethernet port has the public IP on it and is connected to the LAN. The Aux port which has the connector with 16 cables coming out of it is connected to the console port of the device.

Richard Burts Wed, 10/29/2008 - 19:57

Uzma

We can only deal with what you tell us. So please be careful to be accurate in your description of what is going on.

I do not believe that the Aux port supports the connector with 16 cables. If you are really using the Aux port then I believe that it would be a single cable. And if you are really using the 16 port connector then I believe that it must be the Asyn connection.

If you are using the 16 cable connector then the question would be whether you are really using cable 8. What you describe in your post would use cable 8. The symptoms that you describe of attempting the connection and it hanging would be produced if you were using a physical connection that was not the first cable 8 (are you perhaps using the second cable 8 in the connector - which would be treated as 16 in your config)?

HTH

Rick

uzmausmani Thu, 10/30/2008 - 07:21

Sorry for the confusion. I'm setting up a terminal server for the first time. I am using the 16 cable connector but they are all physically numbered from before. Thats the number I am using as the line number for the connection. I tried changing the cables from no. 8 to the one numbered 1, modified the ip host command but when I telnet using the command telnet 172.22.2.1 200x it always telnets into itself and hangs...I've tried using different x in the hope that maybe I have been using the wrong line number but it gives me the same result. I dont know what else to do. Please help. Thanks.

cisco steps Mon, 11/03/2008 - 14:07

You are using the first TTY line for your reverse telnet. Can you confirm that you are connecting that first line to the device to which you want to console? Can you specify what kind of cable connection you are using? Can you confirm that the device to which you want to console will accept a direct connection on the console port.. if all is good then chk the two async ports on 2511 router.The lower port is labeled ASYNC 1-8, and the upper port is labeled ASYNC 9-16. Could it be that you are connecting to the upper port which is line 9-16?

tom.storey Tue, 11/04/2008 - 05:26

You need to connect line 8 from your octal cable(s) to the console port of the other device if you are telnetting to port 2008.

The likely reason it is "hanging" is that you are not getting a response from the other device, possibly because you have the wrong terminal cable plugged in, or the port settings dont match at both ends.

To determine if it has really hung, first press Ctrl-Alt-6 and let go, then press X. This should drop you back to the console of the 2511. Press enter to resume your session.

nevilles45 Thu, 11/06/2008 - 07:35

Hi Guys,

I'm reading this with great interest, as I have the same problem as Uzma, and could really do with some help. First of all, I have a 2511 access server (IOS 10.2) with two octal cables connected to a stack 11 routers and switches (various flavours of IOS from 11.x to 12.3). I've also have followed the configuration instructions in the following link : http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a008014f8e7.shtml#cs

However, when I reverse telnet to a device from the access server (via a PC connected to the Ethernet port), I have the same problem i.e. Telnet opens, and the cursor drops to the next line with no response from the device. CTRL+SHIFT+6 X returns me to the access server prompt.

I have taken care to do the following:

1. Connect the correct rolled cable to the target device console port in line with the port configured in the host table.

2. Configured the access servers tty lines 1 16 in the manner prescribed.

3. Configured the target devices console port in the manner prescribed.

I've yet to try upgrading the access server, and replacing one or other octal cable.

This is troubling me as this should be a straight forward setup, but is proving otherwise. Help would be much appreciated.

Nevski

Richard Burts Thu, 11/06/2008 - 09:23

Nevski

It would be helpful if you would post your config. We can tell much more from that than we can from your saying that it is configured as proscribed.

Also if you connect a console cable from the PC directly to the target device do you get a successful console session?

HTH

Rick

nevilles45 Thu, 11/06/2008 - 10:04

Hi Rick

I'll send the configs over this evening. Yes I can directly telnet into the target device via a directly connected Cisco rolled cable and have got a successful session.

Speak soon

Neville

Richard Burts Fri, 11/07/2008 - 10:08

Neville

While I am not sure that I see any big issues in the configurations I do have a couple of suggestions for changes. On the target router you have this configured under line console 0:

transport preferred telnet

Pretty obviously the console does not do telnet. So I suggest that you remove this.

On the access server you have this configured under line 1 16:

transport input telnet

transport output telnet

but you really do not want these lines to do telnet. I suggest that you remove these lines or move them to the vty lines where you apparently do want to do telnet.

Give these changes a try and let us know if the behavior changes.

HTH

Rick

nevilles45 Mon, 11/10/2008 - 16:48

Hi Rick

I have taken your advice and applied the changes you suggested. In fact, I erased the configs from both routers and started again. Unfortunately, the reverse telnet still does not work. I have run "debug ip packet" with term mon on, in-order to see what is going on.

Here is the output. I thought that perhaps there is a cabling issue but now I'm not so sure.

Your thoughts would be appreciated.

Thanks

Neville

Richard Burts Mon, 11/10/2008 - 20:49

Neville

First a suggestion: remove both of these lines under the configuration of line 1 16:

transport input none

transport output none

probably the best way is to configure:

line 1 16

default transport input

default transport output

and then an observation: there is a serious mismatch between what you have posted as the configuration of the access server and the output of debug. The configuration clearly shows that ROUTER-BB1 is at 172.16.1.1 but the debug shows that attempting to reach ROUTER-BB1 results in:

access-server#router-bb1

Trying ROUTER-BB1 (192.168.1.1, 2004)... Open

How does 172.16.1.1 turn into 192.168.1.1? I am not sure whether there is some case sensitive issue about the name, or whether you have been editing the config information before posting it, or whether you have a seriously buggy version of code.

Perhaps it would be helpful if you would post the output of show ip interface brief and the output of show host from the access server.

You might also try testing by using just the ip address rather than the name:

telnet 172.16.1.1 2004

HTH

Rick

nevilles45 Tue, 11/11/2008 - 04:44

Hi Rick,

My apologies, I've changed the loopback from 172.16.1.1 to 192.168.1.1. I'll try the defual transport input/output comands later this evening. Here are the latest configs and the debug output again.

Cheers

Neville

nevilles45 Tue, 11/11/2008 - 11:55

Hi Rick,

Thanks for your advice, however the command "default transport input" etc is not supported under IOS 10.2 :-)

Thanks

Neville

nevilles45 Wed, 11/12/2008 - 06:09

Hi Rick,

Finally I've sorted this out. It seems that starting from scratch in terms of configs, and paying close attention to using the correct rolled cable in relation to the async port done the trick. Just a few lines to thank you assistance.

Rgds

Neville

Richard Burts Wed, 11/12/2008 - 08:48

Neville

I am glad that you have got this sorted out. Thanks for posting back to the thread and indicating that it was resolved and how you resolved it. It makes the forum more useful when people can read about a problem and can read what was done to resolve the problem.

You might use the check box in the rating system to indicate that the problem is solved. This would make it easier for people to identify the problem as one that was resolved.

HTH

Rick

Actions

This Discussion