Stat Routing Problem

Unanswered Question
Oct 29th, 2008
User Badges:

I have a weird routing Problem. Our network is a class (A) network with multiple remotes attached to our central site. All remote sites have default routes pointing to local router. Local router has a default route to our hosted managed firewall for Internet. Everything has worked fine until 2 days ago when an additional router had to be added. A static route was added to accomodate this of

ip route 64.57.148.118 255.255.255.255 100.100.100.220 Now all access to addresses of 64.xxx.xxx.xxx gets routed to the new router not our firewall. It appears as if it is treating everything as a class (A) network. Is there a way around this.


Router Configuration


xxxxxx#

Current configuration : 1184 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname xxxxx

!

logging queue-limit 100

enable secret xxx

enable password xxxxx

!

ip subnet-zero

!

no voice hpi capture buffer

no voice hpi capture destination

!

mta receive maximum-recipients 0

!

interface Multilink1

ip address 10.2.1.1 255.255.0.0

ppp multilink

multilink-group 1

!

interface FastEthernet0/0

ip address 100.100.120.1 255.0.0.0

speed auto

duplex auto

!

interface Serial0/0

no ip address

encapsulation ppp

compress stac

ppp multilink

multilink-group 1

!

interface Serial0/1

no ip address

encapsulation ppp

compress stac

ppp multilink

multilink-group 1

!

interface Serial0/2

ip address 10.3.1.1 255.255.0.0

encapsulation ppp

!

interface Serial0/3

no ip address

shutdown

!

router eigrp 1

redistribute connected

network 10.0.0.0

network 100.0.0.0

auto-summary

!

ip http server

no ip classless

ip route 0.0.0.0 0.0.0.0 100.100.100.200

ip route 64.x.x.118 255.255.255.255 100.100.100.220

!

dialer-list 1 protocol ip permit

!

call rsvp-sync

!

mgcp profile default

!

dial-peer cor custom

!

line con 0

line aux 0

transport input all

line vty 0 4

password xxxxx

login

!

end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Harold Ritter Wed, 10/29/2008 - 17:20
User Badges:
  • Cisco Employee,

Roy,


This appears to be an issue related to the "no ip classless" command. The traffic to 64.0.0.0/8 is probably not forwarded to the new router but rather dropped on the local router because of the stateful behavior.


Simply configure "ip classless" to fix the issue.


Regards

Harold Ritter Wed, 10/29/2008 - 17:50
User Badges:
  • Cisco Employee,

One more thing. You should also enable "ip cef".


Regards

Actions

This Discussion