adding link failover to DIA and mesh that already uses bpg

Unanswered Question
Oct 30th, 2008

I have a 10mb connection to XO with 2 vlans for DIA (direct internet access) and a multisite mesh network. The DIA uses static routing and the MESH uses ebgp. Now we are adding a redundant (diverse path)link for the 10mb Eth connection. I'm not sure how to configure BGP for link failover when I already have bgp for my mesh. Is there a standard answer for this problem or what settings questions should I be asking my ISP?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
TomWills1 Fri, 10/31/2008 - 14:13

To eleborate: I currently have a 10mb ethernet link with two vlans. One vlan is for Internet traffic that XO hands off from their cloud. There is simple static routing pointing a default route to the Internet from us to XO and a route from XO to our assigned /26 address space for web traffic. The second Vlan is for our MPLS\Mesh Network between three sites. We are using BGP for the site to site routing over this vlan.

Now we are adding a second ethernet connection for last mile redundancy. If I didn't have vlans and only had the mesh network I assume I would just have two neighbor statements.

But I have two vlans on the link and they need to remain seperate. I'm thinking of using two network statements for the mesh network and adding a secondary static default route for the DIA link. So if my primary 10mb link fails. The BGP would failover the mesh vlan connectivity and the secondary default route would failover the DIA.

interface FastEthernet0/0/0

description WAN_XO_10meg_port

no ip address

duplex full

speed 10

service-policy output voip

!

interface FastEthernet0/0/0.1535

description ISP_DIA_to_LAN_DMZ

encapsulation dot1Q 1535

ip address 255.255.255.252

ip nat outside

ip virtual-reassembly

zone-member security outside

no cdp enable

!

interface FastEthernet0/0/0.1536

description ISP_MESH_to_LAN_Inside

encapsulation dot1Q 1536

ip address 255.255.255.252

no cdp enable

!

interface FastEthernet0/0/1

description future XO failover

no ip address

shutdown

duplex auto

speed auto

router bgp 7014

no synchronization

bgp log-neighbor-changes

network 10.3.0.0 mask 255.255.0.0

network 10.10.0.0 mask 255.255.0.0

network 10.11.0.0 mask 255.255.0.0

network 10.154.0.0 mask 255.255.252.0

neighbor remote-as 2828

no auto-summary

!

ip route 0.0.0.0 0.0.0.0

ip route 10.3.0.0 255.255.0.0 10.10.0.139

ip route 10.10.0.0 255.255.0.0 10.10.0.3

ip route 10.11.0.0 255.255.0.0 10.10.0.3

ip route 10.154.0.0 255.255.252.0 10.10.0.1

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

I'm thinking this may be a solution ??? <<<<<<<<<<<<<<<<<<<<<

interface FastEthernet0/0/1

description future XO failover

no ip address

interface FastEthernet0/0/1.1535

description DIA FAILOVER LINK

encapsulation dot1Q 1535

ip address 255.255.255.252

!

interface FastEthernet0/0/1.1536

description MESH FAILOVER LINK

encapsulation dot1Q 1536

ip address 255.255.255.252

router bgp 7014

neighbor remote-as 2828

! -----Failover for Mesh vlan-----

neighbor remote-as 2828

ip route 0.0.0.0 0.0.0.0

!----Failover for DIA--------------

ip route 0.0.0.0 0.0.0.0 10

Actions

This Discussion