Reload due to a software-forced crash

Unanswered Question
Oct 31st, 2008

Hi, I got "Reload due to a software-forced crash" problem during the boot of one AS5350 earlier. Then I reloaded the a boot image to bootflash by xmodem. Now I can login the router by boot mode. But it replied "Bad device info block" when I show either flash or bootflash. So I can't load any new image to the flash.

Can anyone guide me how to solve this problem? Thank you.

Router(boot)#show ver

Cisco Internetwork Operating System Software

IOS (tm) 5350 Software (C5350-BOOT-M), Version 12.3(15b), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2005 by cisco Systems, Inc.

Compiled Thu 25-Aug-05 15:59 by ssearch

Image text-base: 0x60008AFC, data-base: 0x60480000

ROM: System Bootstrap, Version 12.2(1r)1, RELEASE SOFTWARE (fc1)

Router uptime is 57 minutes

System returned to ROM by error - a Software forced crash, PC 0x60161210 at 10:34:30 EST Fri Oct 31 2008

System image file is "bootflash:c5350-boot-mz.123-15b.bin"

......

Backplane HW Revision 1.0, Flash Type 5V

2 FastEthernet/IEEE 802.3 interface(s)

2 Serial network interface(s)

512K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

16384K bytes of processor board Boot flash (Read/Write)

Boot output:

System Bootstrap, Version 12.2(1r)1, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/cgi-bin/ibld/view.pl?i=support

Copyright (c) 2001 by cisco Systems, Inc.

bus error while trying to access flash - addr = 0xb0000000

cannot read flash info

******************************************

Unsupported system flash simms detected

Replace flash simms

Both flash simms must be of the same type

******************************************

AS5350 platform with 524288 Kbytes of main memory

bus error while trying to access flash - addr = 0xb0000000

cannot read flash info

getdevnum warning: device "flash" has size of zero

bus error while trying to access flash - addr = 0xb0000000

cannot read flash info

getdevnum warning: device "flash" has size of zero

open: read error...requested 0x4 bytes, got 0x0

trouble reading device magic number

boot: cannot open "flash:"

boot: cannot determine first file name on device "flash:"

System Bootstrap, Version 12.2(1r)1, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/cgi-bin/ibld/view.pl?i=support

Copyright (c) 2001 by cisco Systems, Inc.

bus error while trying to access flash - addr = 0xb0000000

cannot read flash info

******************************************

Unsupported system flash simms detected

Replace flash simms

Both flash simms must be of the same type

******************************************

AS5350 platform with 524288 Kbytes of main memory

Self decompressing the image : #################### [OK]

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Sat, 11/01/2008 - 10:35

Hello David,

>>Unsupported system flash simms detected

Replace flash simms

Both flash simms must be of the same type

the system thinks the two chips are of different type.

and also:

bus error while trying to access flash - addr = 0xb0000000

cannot read flash info

I'm afraid you cannot even format the flash because you cannot access it.

Verify that both chips are well seated in the slots.

Hope to help

Giuseppe

Davy Ad Tue, 12/16/2008 - 09:07

Hello Giuseppe,

is there any way to get IOS version back if it accidentally delete?

Thanks

David

Giuseppe Larosa Tue, 12/16/2008 - 09:48

Hello David,

the answer is yes but different ways can be needed depending on the state of the router.

If the router is alive with IOS running you can use the command

copy tftp flash

You need to have the right image on a TFTP server.

otherwise if the device has been reloaded without finding a valid IOS image it will stuck in rommonitor

you should see on the console a prompt like

rommon

for C5320 in this case the file can be placed in the flash using Xmodem on the console connection see

http://www.cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a008015bfac.shtml

other platforms are able to perform tftp from rommonitor

In any case the first step is to have the right image available on a PC with a TFTP server running

Hope to help

Giuseppe

Davy Ad Tue, 12/16/2008 - 11:30

Thanks

It is C2600 Router and in rommonitor and there is no IOS in it. I am thinking of using The same Model with the IOS to copy ios from other C2600 to the deleted IOS c2600 by using Crossover cable with same subnet.

David

sachinraja Tue, 12/16/2008 - 14:08

Use this:

rommon 1> IP_ADDRESS=172.15.19.11

rommon 2> IP_SUBNET_MASK=255.255.255.0

rommon 3> DEFAULT_GATEWAY=172.16.19.1

rommon 4> TFTP_SERVER=172.15.20.10

rommon 5> TFTP_FILE=/tftpboot/c2600-i-mz

what does the dir flash: command give ? does it show a valid IOS ? rommon has limited configuration information, and you should be able to restore from it. have a look at this doc.. might help you:

http://www.cisco.com/en/US/docs/routers/access/2600/hardware/installation/guide/2600appB.html

Hope this helps

Raj

Davy Ad Tue, 12/16/2008 - 14:25

Thanks

This is a lab router without any connection to TFTP server and i do not think i need default gateway i am thinking of loading it from another same model. But no live connection it is a stand alone router , is for Team Lab.

Any other suggestion would be appreciated

Thanks

Actions

This Discussion