netconfig devicefile invalid argument

Answered Question
Oct 31st, 2008
User Badges:

Hi,


I use LMS 3.1


I run exactly the same command but I get th following message:


cwcli netconfig createjob -u admin -p password -devicefile /opt/CSCOpx/bin/test.list -commandfile command.file -policyfile policy.in -description "cwcli netconfig job" -mode config


<cwcli> FATAL - NETCLI014:Netconfig createjob command failed

<cwcli> FATAL - Invalid argument: officeuk


my test.list file content is:


cat test.list

officeuk


The weird thing is that if I run the same command but without having a file but device (-device officeuk), it works!


I can't see any reason why this is not working, can u?


what is the correct argument did i miss something? I read the netconfig's manual and it is said to enter devices name contained in RME database.


regards


alex

Correct Answer by Joe Clarke about 8 years 6 months ago

This is a bug in the documentation. The device file must be an extension of the regular CLI. So, the syntax is:


-device device1[,device2[,device3[,...]]]


In your case, this will work:


% cat test.list

-device officeuk

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Joe Clarke Fri, 10/31/2008 - 11:45
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This is a bug in the documentation. The device file must be an extension of the regular CLI. So, the syntax is:


-device device1[,device2[,device3[,...]]]


In your case, this will work:


% cat test.list

-device officeuk

durale1789 Mon, 11/03/2008 - 03:41
User Badges:

it worked! thank you very much


i guess if i have more then 1 device the file will contain something like that:


- device device1,device2,device3,etc...


regards


alex



Actions

This Discussion