CME:how to block external call to external call

Unanswered Question
Nov 1st, 2008

cme have the four fxo and AA,when the external calls come in,and dial 9+ pstn num,it can call from external call to another external call,how can blocking?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Najeeb Mohammad Sun, 11/02/2008 - 00:33

Hi,

try to use this command

#call application voice aa max-extension-length 5

This option declares the maximum length of the extension that the user can dial when dial-by-extension-option is chosen. The default value is 5. The value can be 0 with no restriction up to x digits.

or try

3.

Configure Class of Restriction (COR) to block call transfers from B-ACD to PSTN numbers. The sample configuration below prevents the B-ACD from transferring calls out to local and long distance PSTN numbers. The B-ACD can still transfer calls to internal extensions.

Below is an example of such a configuration:

dial-peer cor custom

name longdistance

name local

!

!

dial-peer cor list call-longdistance

member longdistance

!

dial-peer cor list call-local

member local

!

dial-peer cor list block-pstn

!

dial-peer voice 1 voip

corlist incoming block-pstn

application aa

destination-pattern 1000

session target ipv4:192.168.1.1

incoming called-number 1000

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 2 pots

corlist outgoing call-longdistance

destination-pattern 91..........

port 0/2/0

!

dial-peer voice 3 pots

corlist outgoing call-local

destination-pattern 9[2-9]......

port 0/2/0

Thanks

Najeeb

guoqiang.li Sun, 11/02/2008 - 01:53

Hi, Najeeb:

it seems use on B-ACD AA TCL,but I is using

its-CISCO.2.0.2.0.tcl.max-extension-length has no effect to its-CISCO.2.0.2.0.tcl.

guoqiang.li Sun, 11/02/2008 - 03:00

Hi,

i try the max-extension-length and COR,it doesn't work,the AA still can tranfer to PSTN numbers

!

!

dial-peer cor custom

name longdistance

name local

!

!

dial-peer cor list call-longdistance

member longdistance

!

dial-peer cor list call-local

member local

!

dial-peer cor list block-pstn

!

!

dial-peer voice 10 pots

corlist outgoing call-longdistance

translation-profile outgoing telcom

service aa

destination-pattern 9.T

port 0/1/0

!

dial-peer voice 11 pots

corlist outgoing call-longdistance

translation-profile outgoing telcom

service aa

destination-pattern 9.T

port 0/1/1

!

dial-peer voice 12 pots

corlist outgoing call-longdistance

translation-profile outgoing telcom

service aa

destination-pattern 9.T

port 0/1/2

!

dial-peer voice 300 voip

corlist incoming block-pstn

service aa

destination-pattern 51190000

session target ipv4:10.1.3.254

incoming called-number 51190000

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

guoqiang.li Mon, 11/10/2008 - 18:05

hi,mohdnajeeb:

do you have any other idea? thank you very much.

Anees Ur Rehman Fri, 11/14/2008 - 05:19

hi,

i am having same issue with my telephony setup, I will apply your provided command/COR configs and let you know if its works...

Anees Anjum

guoqiang.li Sun, 11/02/2008 - 01:18

cme-test(config-app)# service aa

cme-test(config-app-param)#param max-extension-length 5

Warning: parameter max-extension-length has not been registered under aa namespace

cme-test(config-app-param)#

mohammad.elshafie Wed, 06/15/2011 - 05:16

hi guogiang,

wishing u r fine

I have the same problem now, did u find the solution for this issue?

thanks

Anees Ur Rehman Wed, 06/15/2011 - 05:34

Hi All, sorry for the late response;

I had applied following configs and they worked fine for me, please try these and let me know if they work. p.s configurations might vary depeneding on your deployment scenario!

dial-peer cor custom

name On-Net

name Off-Net

dial-peer cor list Call-On-Net

member On-Net

dial-peer cor list Call-Off-Net

member Off-Net

dial-peer cor list Call-Both

member On-Net

member Off-Net

dial-peer voice 200 pots

corlist outgoing Call-Both

destination-pattern 9.T

port 0/0/0:XX

dial-peer voice 201 pots

corlist incoming Call-On-Net

service aa

incoming called-number XXX

port 0/0/0:XX

Dragan Ilic Thu, 02/13/2014 - 06:09

We changed and added only this italic part for this problem in initial script:

proc act_GotDest { } {

    global dest

    global callInfo

    global oprtr

    global busyPrompt

    puts "\n proc act_GotDest"

    set status [infotag get evt_status]

    set callInfo(alertTime) 30

    if {  ($status == "cd_004") } {

        set dest [infotag get evt_dcdigits]

                if { [string length $dest] > 3 } {

                        act_Cleanup

                }

        if { $dest == "0" } {

                set dest $oprtr

        }

Everything else remains same...this way only 3 digit are allowed to be in destination pattern...

HTH,

Dragan

yahsiel2004 Thu, 02/13/2014 - 06:17

Guys you know you can just deny transfering calls beyond 4 digits (or however many digits) under the telephony-service.

telephony-service

transfer-pattern ....

HTH

Regards,

Yosh

Gulyaev Semyon Wed, 02/19/2014 - 00:11

if { [string length $dest] > 3 } {

                        act_Cleanup

                }

Thank you, Dragan. Your code was helpful in our problem resolving. Because when we add

set param1(maxDigits) 4 in script we limit outside-to-outside calls, but if on ext. set call-forwarding to outside number then outside call doesn't go to forwarding number.

Semyon.

Dragan Ilic Thu, 02/13/2014 - 06:21

Didn't play with that so can't comment...but you must admit that scripting looks, if nothing else, more powerfull

BR,

Dragan

Actions

This Discussion