Need to recover from an IOS downgrade

Unanswered Question
Nov 2nd, 2008

Hi, I tried to downgrade a 2611XM router but apparently picked a wrong image and now have a router which does not appear to have any ethernet/serial interfaces. I do have a console connection through another router (using octopus cabling to all console ports). I tried to use xmodem with my Hyperterm but it always fails after a few packets. Any suggestions?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
scottmac Sun, 11/02/2008 - 05:37

Make sure all handshakes (hardware and software) are turned off for the terminal program you're using.

Also make sure you are using the correct version of Xmodem (regular (256 byte blocks), versus Xmodem 1k).

How does it fail? Does it stall forever, or do you get a string of CRC error'd blocks?

Good Luck

Scott

onnobrouwer Sun, 11/02/2008 - 07:10

I am using hyperterm to connect through a console router to the target system. The line settings for this console router I normally tweak with txspeed and rxspeed to speed up the download. However even at the defaults (9600) I still cannot get it to work.

line 33 48

session-timeout 60

exec-timeout 0 0

no exec

transport input telnet

The command I use on the target router:

xmodem -c ios.bin

After 7 packets Hyperterm states its getting retry requests. After this on the target router I see:

Timeout waiting for data - aborting download...

I tried with standard xmodem selection on the Hyperterminal transfer file.

scottmac Sun, 11/02/2008 - 13:21

It appears the your target router is not responding, or the response is not making it back to the sending system.

Can you set it up such that the sending system is directly attached to the receiving system? i.e., either send from the console router, to connect your pc directly to the receiving router.

Maybe copy / ftp a test file to the console router and try sending it to see if the errors still occur.

Good Luck

Scott

Richard Burts Mon, 11/03/2008 - 12:09

Onno

Even though it does not show Ethernet interfaces after it boots, it may be that in rommon the router could access its Ethernet interface. If you get to rommon you might try to use the tftpdnld command.

I would connect the server/PC with the image that you want to use directly to the Ethernet interface of the router, start a TFTP server and make sure that it is pointing to the folder/directory where the image is located. To use the tftpdnld command you will need to set some variables. If it works tftpdnld would be much more efficient a solution than xmodem.

HTH

Rick

Actions

This Discussion