cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
369
Views
13
Helpful
4
Replies

QoS

bericaleb
Level 1
Level 1

Hi

I have a 128Kbps Leased line link between two of our branch offices. The link is used for both voice and data. I would like to configure QoS on the cisco routers 1841. Pls help. The backup link between the two branches is an ISDN BRI.

1 Accepted Solution

Accepted Solutions

HI, [Pls RATE all informative POST]

QoS for Marking @ LAN Interface:

=================================

!

class-map match-all Voice

match access-group

class-map match-all Data

match access-group

policy-map Marking

class Voice

set ip precedence 5

class Data

set ip precedence 2

!

Qos for Bandwidth Reservation:

===============================

!

class-map match-all Company-Data

match ip precedence 2

class-map match-all Company-Voice

match ip precedence 5

!

!

policy-map QOS-128K-Company

class Company-Voice

priority 32

class Company-Data

bandwidth 96

!

Applying at WAN Interface:

===========================

interface WAN Interface

service-policy output QOS-128K-Company

Hope I am Informative. Pls RATE all Informative POST.

Best Regards,

Guru Prasad R

View solution in original post

4 Replies 4

ohassairi
Level 5
Level 5

use the web interface (SDM) of your router. there is a wizard for qos.

Hi,

1.On your router mark the voice packet & data packet on the basis of either vlan ( voice/data) or trust the marking done by LAN switches.

class-map voice-traffic

match access-group 100

class-map data-traffic

match access-group 101

policy-map WAN-POLICY

class voice-traffic

bandwidth

priority

class data-traffic

bandwidth

interface wan-interface

service-policy output WAN-POLICY

access-list 100 permit ip voice traffic

access-list 101 permit ip data tarffic

HTH...rate if helpful..

HI, [Pls RATE all informative POST]

QoS for Marking @ LAN Interface:

=================================

!

class-map match-all Voice

match access-group

class-map match-all Data

match access-group

policy-map Marking

class Voice

set ip precedence 5

class Data

set ip precedence 2

!

Qos for Bandwidth Reservation:

===============================

!

class-map match-all Company-Data

match ip precedence 2

class-map match-all Company-Voice

match ip precedence 5

!

!

policy-map QOS-128K-Company

class Company-Voice

priority 32

class Company-Data

bandwidth 96

!

Applying at WAN Interface:

===========================

interface WAN Interface

service-policy output QOS-128K-Company

Hope I am Informative. Pls RATE all Informative POST.

Best Regards,

Guru Prasad R

Joseph W. Doherty
Hall of Fame
Hall of Fame

The other posters have provided CBWFQ policies that might work for you. Some other considerations and thoughts include:

128 Kbps is tight for sharing data and voice. Assuming your voice is VoIP, bandwidth demand varies based on the codec you'll be using. Even when the codec uses little bandwidth, you'll still need to account for IP header bandwidth expansion. For G711 assume about 92 Kbps, for G729a assume about 33 Kbps (per call).

What's important is insuring VoIP goes first out your serial interface. With CBWFQ, a class defined with "priority" assures this. You need to insure that voice bearer packets, and only those packets, are placed into your priority class. You might find your VoIP devices already pre-mark their voice packets, often with a DSCP EF, if they do you can match against it.

Assuming pre-marked VoIP packets, another variation of CBWFQ, for two G729a flows, might be:

e.g. (syntax might be incorrect)

class-map VoIP

match ip dscp EF

policy-map CBWFQ

class VoIP

priority 66

class class-default

fair-queue

serial #

service-policy output CBWFQ

As a rule-of-thumb, Cisco recommends you don't allocate more than 1/3 of the link for priority traffic. My example violates that with two G729a calls (and so would one G711).

If you're only going to have just one special class, I recommend fair-queue for other traffic. This is especially important since we haven't also treated the call's control traffic as special.

When a policy is in action, check that your VoIP packets are being identified by the priority class and that they aren't being dropped (a priority class can also cap the bandwidth at the value you specific).

Other issues you might run into, again since your overall bandwidth is so small, Cisco recommends using link fragmentation interleaving (LFI) when the bandwidth is less than 768 Kbps. What might also help is using cRTP. I haven't had to use either of these features, but perhaps someone with experience with them might post.

Lastly, I doubt you'll need to configure it, but sometimes reducing the interface's hardware queue with tx-ring-limit is necessary too.

PS:

What you might also try is the AutoQoS command, if supported. I recall one of its variants was dedicated just for VoIP support, but with it too, I don't have practical hands-on experience.

PPS:

You might also consider posting either to the QoS topic and/or Voice forums.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: