Error code 111 when migrating 4.3.6 config to 6.0.1

Unanswered Question
Nov 3rd, 2008
User Badges:

Hi,

After setting up e new box (I'm migrating from a MARS 20 to a MARS 110) and exporting the configuration data to an NFS partition, I'm getting an Error Code 111 when I try to import the config files. The complete message is :

....

Invoking binary config importing procedure.....

Checking schema...

File from 04_3_60_to_06_0_13.sql missing from schema...

Configuration import field with error code : 111

Configrestore failed!

Error: failed to import config data.


I don't know how to proceed -- has anyone else run across this type of problem?


Thanks, Joe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mchin345 Fri, 11/07/2008 - 12:40
User Badges:
  • Silver, 250 points or more

I understand you're having an issue upgrading your MARS-20 (4.x) to the MARS 6.0 software. Unfortunately, there is no upgrade path for the Gen1 MARS (20,50,100,200). To run the 6.x software you must use a special procedure which essentially involves backing up the entire device, re-imaging it to 6.x (which erases the entire configuration and all data) and then re-importing your data. If you aren't particularly attached to your 4.x configuration you save yourself time up front by simply re-imaging to 6.x and reconfiguring the device once the re-image is complete. And the procedure for migrating here:

http://www.cisco.com/en/US/docs/security/security_management/cs-mars/6.0/migration/guide/dmigrate6x.html

(You'd be following Scenarios and Taskflow 2.a from Table 3; Gen 1 running 4.3.6 to Gen 1 [same hardware])

If you're considering migration, please read the document in its entirety before beginning the process as failure to perform this process correctly may result in the loss of all of your current data/configuration.


joe.favia Mon, 11/10/2008 - 01:51
User Badges:

Hi,

Sorry, but I don't get it. Why should I follow the instructions for a SAME HARDWARE scenario when I'm moving from a MARS 20 to a MARS 110? Are there errors in the manual?


Regards, Joe

joe.favia Mon, 11/17/2008 - 06:48
User Badges:

Hi,

The problem got solved by re-imaging the MARS 110 box to version 6.0.1 with the Recovery DVD. After doing that the PNIMP IMPORT CONFIG worked fine. I'm now monitoring the new version to see if everything works fine. It appears to have some issue with rules and fine tuning/drop rules.


Cheers, Joe

zentner Tue, 11/18/2008 - 06:38
User Badges:

Hello,


today I was running into the same problem. I tried to migrate an old MARS 20 (Gen 1) box running 4.3.6 to a new MARS 25 (Gen 2) box running 6.0.1. The new box was delivered with version 5.3.2 and I had to do the whole upgrade path to get version 6.0.1 running on it. As described in the manual I tried to import the config of the old box which was being exported successfully to a NFS server. Trying to import it to the new machine resulted in the same error message as you mentioned above. According to your message Joe I may ask whether I also should re-image the new box with a recovery DVD to version 6.0.1, then re-configuring it with basic network settings and being able afterwards to import the config of the old box. Do you suggest such an upgrade path? What are your further experiences after the import?


Regards,

Markus


zentner Wed, 11/19/2008 - 06:03
User Badges:

Hello,


as suggested by Joe I did a re-imaging of the new box (option 1 Local Controller). Afterwards the old config could be imported without any problems. I'm currently importing old events.


Markus

joe.favia Wed, 11/19/2008 - 07:31
User Badges:

Hi Markus,


I'm up and running since I re-imaged the MARS 110 with the 6.0.1 Recovery DVD. The configuration and all events have been imported correctly, but you might run into some problems regarding misaligned IPS signatures (I read that there is a patch available in CCO!) or some other bug regarding events that trigger the wrong type of incident (I got this bug and am waiting for a fix).

I'm glad to have been of some help to others.


Regards, Joe

bgl-group Wed, 01/14/2009 - 02:25
User Badges:

I've just got the same problem as this.


I am using a MARS20 which was running 4.3.6 and has been reimaged to 6.0.2 using a recovery DVD.


The backup went correctly (I even ran two backups of the config) but the import fails on the same message.


Any ideas.


Giles Cooper


Actions

This Discussion