Crypto Keepalives/DPD not working properly since 7.x upgrade

Unanswered Question
Nov 4th, 2008
User Badges:

Hi all


We're having problems with IPSec tunnels going down and not coming back up by themselves since the upgrade to 7.x. We never had this problem on 6.x, and connections to other manufacturers' VPN devices as well as IOS devices appear to be affected.


We have this configured for the tunnel-attributes:


isakmp keepalive threshold 30 retry 2


But it does not seem to help. The Pix also reports that the command is deprecated, but does not provide an alternative.


On the IOS side, we have this configured:


crypto isakmp keepalive 30 2 periodic


Any ideas how we can resolve this short of reverting to 6.x?


Thanks


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
acomiskey Tue, 11/04/2008 - 06:38
User Badges:
  • Green, 3000 points or more

The command is located in the tunnel-group configuration. Is this where you have it?


tunnel-group ipsec-attributes

pre-shared-key *

isakmp keepalive threshold 30 retry 2

osiristrading123 Tue, 11/04/2008 - 10:35
User Badges:

This has just happened again - if I issue a "clear crypto sa", it fixes the problem.

dbakula01 Sun, 11/09/2008 - 06:09
User Badges:

did you ever get this fixed. I am having the same issue

husycisco Sun, 11/09/2008 - 14:06
User Badges:
  • Gold, 750 points or more

As I remember, 7.2(3) is one of the stable versions of 7.x. I sugegst upgrading to this specific version

osiristrading123 Wed, 11/12/2008 - 07:24
User Badges:

This is still not working properly. What would be the implication of having very low ISAKMP lifetimes, e.g. 180 seconds? Would there be packet drops every 3 minutes?

Actions

This Discussion