DFM Learning Stuck At 40%

Unanswered Question
Nov 4th, 2008
User Badges:

Ciscoworks is running DFM 2.0.12. The discovery progress for learning devices is stuck at 40% for more than 2 hours. Is there any workaround for this? Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Tue, 11/04/2008 - 10:56
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This points to a problem with the DFM data collection process. Additional troubleshooting will have to be done. Please post the NMSROOT/objects/smarts/local/logs/DFM.log and the output of the pdshow command.

Joe Clarke Tue, 11/04/2008 - 11:56
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I don't see anything here that would point to why discovery is hanging at 40% for all devices. It may be a state problem. Restarting the server may get things going again. If not, I suggest you open a TAC service request so they can walk you through the additional steps required for troubleshooting discovery hangs at 40%.

power1pete Tue, 11/04/2008 - 11:59
User Badges:

Thanks for your help Joe. I will open a case with TAC.

pvanvuuren Tue, 11/04/2008 - 23:19
User Badges:
  • Bronze, 100 points or more

We had a similar problem, and in case your DFM version is 3.0.2, here is a solution:


1.Install Patch: cwdfm3_0_3_win.zip ( 52MB )

2.Reboot

3.Install Patch: dfm3.0.0-win-CSCsi019661.1.tar ( 40KB )

4.Reboot


DFM 3_0_3 fixes the 10% stuck bug. But in some cases it introduced a new problem whereby it gets stuck at 40%

CSCsi01966 patch fixes the 40% stuck problem.


These patches are available on CCO for download but one needs a CCO Login. ( http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-dfm )


Cheers

Joe Clarke Wed, 11/05/2008 - 09:57
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Except that this customer is running DFM 2.0.12, and this patch does not apply.

Actions

This Discussion