WebVPN logout button within a displayed page

Unanswered Question
Nov 4th, 2008

Hi,

I've enabled full customization on my ASA 5510 (8.0.4) and use a internal Website as the startpage for the WebVPN.

With the post-plugin I let the user authenticate against the internal site with the login credentials and all seems to work fine.

My problem is, the users only logout from the application inside and not from the WebVPN (don't ask me why?!).

Is there a way to implement a logout link within a page inside the WebVPN? Something like JS?

Thanks,

MB

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ebreniz Mon, 11/10/2008 - 09:44

Customizing the WebVPN Logout Page Following procedure may help you

Step 1 Enter WebVPN customization mode using the customization command from webvpn mode:

hostname(config)# webvpn

hostname(config-webvpn)# customization cisco

hostname(config-webvpn-custom)#

Step 2 Change the title of the Logout box using the logout-title command:

[no] logout-title {text | style} value

Step 3 Change the message of the Logout box using the logout-message command:

[no] logout-message {text | style} value

MaseBarnes Tue, 11/11/2008 - 00:11

Thanks for your reply but I think you missed the point. I want, for example, recode OWA to let the user logout from OWA and WebVPN with one button inside the OWA application.

(It's an own app, not OWA) ;)

Thanks,

MB

tmarschner Mon, 01/12/2009 - 11:50

Hi MaseBarnes,

When I try to enter a post:// URL to set the WebVPN homepage, ASDM tells me that only http and https are allowed. How did you set your start page to use a post url?

Thanks,

Tm

MaseBarnes Tue, 07/28/2009 - 04:00

I finally found a solution on this:

Let's say the link to your ASA is:

https://vpn.company.com

Then apply a content rewrite rule for "*webvpn_logout.html" and disable rewriting for it.

Now you can for example insert a link https://vpn.company.com/+webvpn+/webvpn_logout.html into you MS sharepoint intranet and logout from WebVPN without using the floating toolbar.

HTH somebody ...

MB

nwlogical Thu, 09/30/2010 - 09:36

This does not seem to work with Firefox.  It is working in the IE browser but gives a 404 error in Firefox?  Any ideas why?

MaseBarnes Thu, 09/30/2010 - 23:39

Works with all browsers for me, try to capture the websession und have a look into the packets from the server.

nwlogical Fri, 10/01/2010 - 04:32

Thanks for the quick response.  Can you tell me if I have my no rewrite rule correct?  Here is what I have Resource Mask:

*webvpn_logout.html

There is nothing else in the resource mask it looks just as it is there. I see if I can take a look at the packets just wanted to make sure that is correct?

MaseBarnes Sun, 10/03/2010 - 23:51

Yes ...

rewrite order 2 disable resource-mask *webvpn_logout.html name logout

Actions

This Discussion