PPPoE config to External Modem

Unanswered Question
Nov 5th, 2008

I've looked for quite a while on Exp Exch - but can't seem to find a solution that could solve a problem I'm having with connecting my 1841 to an External Modem using PPPoE.

I can't get the physical interface to use the Dialer interface.

Here is my current config:

---------------------------------------------------------------------

The Interface connected to the modem:

interface FastEthernet0/1

description CCN_Wan$ETH-WAN$

no ip address

ip nat outside

ip virtual-reassembly

speed 100

full-duplex

pppoe enable group global

pppoe-client dial-pool-number 1

no cdp enable

The Virtual Dialer Interface:

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

no ip mroute-cache

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname xxxxxxxxxxxxxxxxxx

ppp chap password 7 xxxxxxxxxxxxxxxxxx

ppp pap sent-username xxxxxxxxxxxxxxxxxx password 7 xxxxxxxxxxxxxxxxxx

ppp ipcp route default

---------------------------------------------------------------------

Here are the 2 interfaces in question, under a "show ip interface brief"

FastEthernet0/1 unassigned YES NVRAM up up

Dialer1 unassigned YES NVRAM up up

---------------------------------------------------------------------

When I do a "debug ppp auth" and "debug ppp negotiations" - I'm not seeing any sort of status messages on the dialer interface actually trying to communicate via the modem.

If anybody can shed some light on this situation for me, It would be greatly appreciated.

My current IOS for the 1841 is 12.4(13r)T.

Any troubleshooting steps that could be provided would be greatly appreciated

**P.S. The external Modem is a Fiber Optics (FIOS) - So I may be totally barking up the wrong tree in thinking it needs a Dialer Interface**

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Wed, 11/05/2008 - 01:23

Hello Jonathan,

if you don't see in the debug ppp neg and debug ppp authentication any I frame this means there's no server for PPPoE.

If you don't see any I or O frames in the debug that is a different matter.

Ask your provider the type of service they are providing over the fiber link

Hope to help

Giuseppe

usslindstrom Wed, 11/05/2008 - 03:33

Thanks very much for helping me through this.

Unfortunately, I have no idea if the Fiber modem is in bridge mode. I can imagine that it is, as I was provided a craptastic router from the ISP for implentation.

Instead of using their router, I would like to use my nice little 1841.

I tried to set this up the same way as an ADSL config - but - Unfortunately, that's where I got stuck.

It's most likely (in my opinion) that the circuit isn't using PPPoE at all (Like you suggested Giuseppe).

If you wouldn't mind enlightening me, what other modes can the Fiber run under?

The ISP gave me a username/password to connect and an Ethernet router, so I just assumed PPPoE... But if anybody has any ideas I can throw into the mix, I would greatly be in your debt.

The ISP only speaks Japanese, and I don't unfortunately, so getting any info from them is like pulling teeth. That, and anything out of the "normal" is frowned upon in Japanese culture (like me using my own router instead of theirs, so usually they're not as cooperative as I would like).

usslindstrom Wed, 11/05/2008 - 03:45

Sorry for the multiple replies - but here is an English translation of NTTs FAQs for Fiber:

-------------------------------------------

Q4

What kind of terminal equipment do I need in order to use the OCN Hikari with FLET'S service?

A4

The required interface is either 10BASE-T or 100BASE-TX. To use the service, you need to have a LAN card and cable of your own. Also, network protocol is PPPoE (PPP over Ethernet).

NTT East/NTT West will later send you the driver for PPPoE, after you applied for OCN Hikari "B FLET'S"/"FLET'S Hikari Premium". Please install the delivered driver and use the service.

Also, if you have applied for OCN .phone (IP phone service), do not use the PPPoE driver "FLET'S connection Kit". Instead, please refer to the manual that came with the IP phone equipment delivered by NTT East/NTT West or check the website.

For further details, please contact NTT East/NTT West.

-------------------------------------------

Q5

Is it possible to use the OCN Hikari with FLET'S service from multiple terminals?

A5

To use the service from multiple terminals, you will need a separate router that has a PPPoE (PPP over Ether) interface and NAT features. Please contact the manufacturer for details.

* For NTT West's FLET'S Hikari Premium service, the subscriber network termination device has several built-in LAN ports, thus with this service you can connect to the Internet simultaneously from multiple terminals.

usslindstrom Wed, 11/05/2008 - 03:55

Also - some output commands:

----------------------------------------

Dialer1 is up, line protocol is up (spoofing)

Hardware is Unknown

Internet address will be negotiated using IPCP

MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, loopback not set

Keepalive set (10 sec)

DTR is pulsed for 1 seconds on reset

Last input never, output never, output hang never

Last clearing of "show interface" counters 3d03h

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/0/16 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 42 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes

0 packets output, 0 bytes

----------------------------------------

FastEthernet0/1 is up, line protocol is up

Hardware is Gt96k FE, address is 001e.1369.46e1 (bia 001e.1369.46e1)

Description: CCN_Wan$ETH-WAN$

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

36273 packets output, 2199120 bytes, 0 underruns

0 output errors, 0 collisions, 89 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

Giuseppe Larosa Wed, 11/05/2008 - 07:24

Hello Jonathan,

it is clear from the QA that PPPoE has to be used.

Be aware that depending on the IOS release you use you can need to enable vpdn

see for example

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a0080126dc0.shtml

try to enable vpdn and to check again with debug ppp neg and debug ppp auth

the modem must behave as a bridge otherwise if it is acting as a router you can only have an ip address assigned by DHCP running on the external box.

Hope to help

Giuseppe

usslindstrom Tue, 11/11/2008 - 22:37

My apologies on taking so long to reply here.

Thanks for helping me through this. The line is still down - but I've downloaded a PPPoE server package (very nice freeware one) - and tested everything.

The router was able to authenticate, and then pick up an IP address from what I assigned to it.

Everything in the Dialer and PPPoE config is set up correctly, but still no line...

Just to test it out, I plugged the laptop directly into the fiber modem, and couldn't get a connection to anything either, so the problem is definatetly the ISP.

Another phone call into em' is in store. :)

Seriously though - thanks for helping me on this.

Actions

This Discussion