NAC Appliance+WS-C4506-E - MAC notification problem

Unanswered Question

Hello all,

I'm trying to get working NAC Appliance 4.5 with WS-C4506-E with MAC notification without any luck. It seems that C4506 detects a MAC change, sends a SNMP trap to NAC Manager and according to what I was able to sniff directly on NAM via tcpdump it even arrives on NAM but I don't see it in Discovered Clients - it's like NAM ignores it completely. It doesn't see the change, therefore doesn't change VLAN on managed port of source switch.

Strangely enough, the same exact configuration does work on c3750 without a problem. I'm using NAC Applience 4.5 and WS-C4506-E with SUP4 and cat4500-ipbasek9-mz.122-46.SG.bin IOS image. It even works with WS-C4506-E in link-up link-down mode which sadly is insufficient for my case as I need IP phones to be connected to switch before the end user.

Can anyone here direct me where the problem should be?

Thank you for any hints


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Daniel Laden Sat, 11/08/2008 - 10:15

Set the logging to all on the CAM, repeat the problem, review the /perfigo/logs/perfigo-log0.log.0 file on the CAM for any clues

j.ridgers Fri, 01/30/2009 - 11:25

Hi Radoslav:

Was there any resolution to this problem? I am running into the exact same problem however I'm using NAC Appliance 4.1.6 and cat4500-ipbasek9-mz.122-31.SGA8.bin.

ziyadr Sun, 02/01/2009 - 13:59

doesn your SNMP community string use special characters like @ ?? i had the exact same problem in the past and had to change my community strings cause versions of code dont like the @ in it.


This Discussion