Quality Management, LDAP issue

Unanswered Question
Nov 6th, 2008

I have a problem with QM 2.4, the agent has to download they configuration from the LDAP service but then i looked at the log files of the agents ane every time the logfile finishes at this 4 lines


2008-11-06 10:53:51:069 INFO SQM0000 : Successfully initialized voice recording module.

2008-11-06 10:53:51:084 INFO SQM0000 : Processing logon event for DOMAIN\FSALAS.

2008-11-06 10:53:51:569 INFO FKSR0000 : Successfully initialized screen recording module.

2008-11-06 10:53:51:569 INFO FKSR0000 : Connected to the screen recording module at 127.0.0.1 with IP protocol.


No calls are recorded, i have to restart the Quality Management Service like 2 times to get the following lines.


2008-11-06 10:57:44:997 INFO SQM0000 : Successfully initialized voice recording module.

2008-11-06 10:57:45:013 INFO SQM0000 : Processing logon event for DOMAIN\FSALAS.

2008-11-06 10:57:45:044 INFO SQM0000 : Successfully loaded agent data from ldap.

2008-11-06 10:57:45:216 INFO SQM0000 : Successfully loaded CTI information from ldap.

2008-11-06 10:57:45:216 INFO SQM0000 : User logging in: 'DOMAIN\FSALAS', '1.FSALAS', '465'.

2008-11-06 10:57:45:216 INFO QMW4001 SQMAgentWF::SetAgentProfile(): Agent Workflow Loading Profile

2008-11-06 10:57:45:216 INFO QMW4006 SQMAgentWF::SetAgentProfile(): Agent Workflow Enhanced Package

VERSION INFO: SplkSQMXmlParser.dll: Product <Quality Management> Version <2.4.1.16> Pri Build <> Special Build <>.

2008-11-06 10:57:45:497 INFO FKSR0000 : Successfully initialized screen recording module.

2008-11-06 10:57:45:497 INFO FKSR0000 : Connected to the screen recording module at 127.0.0.1 with IP protocol.

2008-11-06 10:57:45:778 INFO FKSR0000 : Successfully retrieved host key: w={D73F1876-3D3A-43C5-A409-E7B6A6DD18DA}.

2008-11-06 10:59:43:218 INFO QMW4003 SQMAgentWF::ProcessCTIEvent(): QM recording saved for user 1.FSALAS-465 with ANI 101890, DNIS 311701, CallID 50716163


As you can see there is aditional Lines about the "Successfully loaded agent data from ldap." after this the desktop and voice starts recording. does any one know why is this happening?, by the way im using AD and the latest SR for WFO-QM 2.4

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Clifford McGlamry Fri, 11/07/2008 - 06:20

Not familiar with this problem specifically, but it may be a Microsoft issue. I had something goofy like this happen previously with another voice application, and this is what we found out.


Find out which of your domain controllers is the PDC for the AD domain your users are in. Then open the network configuration settings on your workstation, and add the IP address of the PDC in as the WINS server.


If this fixes the issue, then you're likely dealing with a setup where it's authenticating across subnets (i.e. domain controllers on one subnet, and your agents/servers on another. If the underlying code is making a netbios call rather than doing it correctly, this will fix that issue.

llozanos81 Fri, 11/07/2008 - 11:32

Hi, thank you for your response, by PDC you mean Global Catalog?


llozanos81 Mon, 11/10/2008 - 14:35

Hi, i already checked that and the WINS server is the AD server with the PDC role, what else do you think i can look at?.

llozanos81 Wed, 02/11/2009 - 08:23

I already Fixed this, you have to Disable Automatic Updates in Enterprise Settings in Quality Management

Actions

This Discussion