WiSM Etherchannel not coming up on 6513

Unanswered Question
Nov 7th, 2008
User Badges:

I have a wism installed on my 6513 but the moment i assign ports g12/1-4 to Po1 and Ports G12/5-8 to Po2 the are no coming up the configuration of the Ports including Po1 and Po2 are as follows:


interface range GigabitEthernet12/1-4

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 137

switchport mode trunk

switchport nonegotiate

no ip address

no snmp trap link-status

mls qos trust cos

no cdp enable




interface range GigabitEthernet12/5-8

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 137

switchport mode trunk

switchport nonegotiate

no ip address

no snmp trap link-status

mls qos trust cos

no cdp enable


wism module 12 controller 1 native-vlan 137

wism module 12 controller 2 native-vlan 137


The moment i assign the ports to their respective channel-group they all goes down, I tried to unshut them manually but no luck. IOS version is (s72033_rp-IPSERVICES_WAN-M), Version 12.2(18)SXF7.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Scott Fella Fri, 11/07/2008 - 04:39
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

DO you have your port channels configured correctly... also make sure you have channel-group mode on.


Here is a link:


http://www.cisco.com/en/US/products/hw/modules/ps2706/products_tech_note09186a00808330a9.shtml


renato.berana Fri, 11/07/2008 - 05:26
User Badges:

Port channels are configured properly, but for unknown reason the etherchannel are not coming up

jakew Fri, 11/07/2008 - 07:08
User Badges:
  • Silver, 250 points or more

Configure the channel-group and enable that first.

Scott Fella Fri, 11/07/2008 - 07:14
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

You have the service ports showing UP? Also, run a show etherchannel load-balance and make sure it is setup for src-dst-ip. if not run this command port-channel load-balance src-dst-ip

renato.berana Fri, 11/07/2008 - 11:27
User Badges:

Yup all service ports are up, i can even access the management GUI but without the etherchannel, once i add the ports to their respective channel-group they are all switching to disabled mode.

krishanmistry Sun, 11/09/2008 - 02:18
User Badges:



Make sure your not using port channels 1-13, use anything above 13 and they should come up, this is a bit of a gotcha with the WiSM.


E.g Port channel


interface Port-channel20

description ***PORT_CHANNEL_WiSM_1_WLC1***

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan #

switchport trunk allowed vlan #,#

switchport mode trunk

no ip address

!

interface Port-channel21

description ***PORT_CHANNEL_WiSM_1_WLC2***

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan #

switchport trunk allowed vlan #,#

switchport mode trunk

no ip address


Interface Example


interface GigabitEthernet2/8

description ***8Gbps_GEC to Switch 2***

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

channel-group 21 mode on


Please rate this post

tkhan Tue, 11/11/2008 - 11:13
User Badges:

If you want to get away from the port channel configuring of the WiSM, try these commands:

wism module controller 1 allowed-vlan

wism module controller 2 allowed-vlan

wism module controller 1 native-vlan

wism module controller 2 native-vlan


These statements are available on SXF5 and later, I think. I'm running 12.2(18)SXF9. (SUP720)


Here is a statement from the documentation:


Note: Software Release 12.2(18)SXF5 introduced new WiSM commands to use with auto-LAG ports (in the high 200 range). These commands can be used instead of steps 5 and 6 . Repeat the two commands for controller 1 and controller 2 in the WiSM module.


wism module controller 1 native-vlan 40


wism module controller 1 allowed-vlan native vlan id(40), vlan id1, vlan2

renato.berana Thu, 11/13/2008 - 04:29
User Badges:

Hi Buddy, i configured port-channel 15 and 16 and the etherchannel are working fine now. the problem now is I am not able to connect to the WiSM management.

tkhan Thu, 11/13/2008 - 06:00
User Badges:

Have you setup your service port vlan? You can use it to check your management interface configurations or use the console port.


Example:

ip dhcp pool wism-service-port

network 192.168.0.0 255.255.255.248

default-router 192.168.0.1

wism service-vlan 192

interface Vlan192

ip address 192.168.0.1 255.255.255.248

end



krishanmistry Thu, 11/13/2008 - 12:21
User Badges:

Make sure the native Vlan for trunk on all 8 interfaces is the management VLAN tag, and make sure the management interface on the WiSM are untagged (0).


Hope this helps,

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode