dial on cisco 1841

Unanswered Question
Nov 7th, 2008
User Badges:

i have cisco 1841 with this configuration below.

i add another interface 1-port ADSLoPTS HWIC. and i want to user 2 dial for connexion and specifie the http on one dial with IP static 41.249.250.10 and smtp on the seconde dial with the new IP Static.


Current configuration : 4016 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname routeur1841

!

boot-start-marker

boot system flash:c1841-broadband-mz.124-15.T.bin

boot-end-marker

!

logging buffered 51200 warnings

enable secret xxx

enable password ****

!

no aaa new-model

ip cef

!

!

!

!

ip domain name yourdomain.com

multilink bundle-name authenticated

!

!

username ***** privilege 15 secret xxx

archive

log config

hidekeys

!

!

!

!

!

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

no mop enabled

!

!

interface ATM0/0/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/35

encapsulation aal5snap

pppoe-client dial-pool-number 1

!

!

interface ATM0/1/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/35

encapsulation aal5snap

pppoe-client dial-pool-number 1

!

!

interface Dialer0

mtu 1492

ip address negotiated

ip directed-broadcast

ip mtu 1452

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname ********

ppp chap password 0 *********

ppp pap sent-username ********* password 0 *********

!

ip route 0.0.0.0 0.0.0.0 Dialer0 10

ip route 192.168.2.0 255.255.255.0 192.168.1.2

!

!

ip http server

ip http access-class 23

ip http authentication local

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface Dialer0 overload

ip nat inside source static esp 192.168.1.2 interface Dialer0

ip nat inside source static tcp 192.168.2.2 110 interface Dialer0 110

ip nat inside source static tcp 192.168.2.2 25 interface Dialer0 25

ip nat inside source static tcp 192.168.1.10 80 interface Dialer0 80

ip nat inside source static udp 192.168.1.2 500 41.249.250.101 500 extendable

ip nat inside source static tcp 192.168.1.2 1721 41.249.250.101 1721 extendable

ip nat inside source static udp 192.168.1.2 1721 41.249.250.101 1721 extendable

ip nat inside source static tcp 192.168.1.2 1723 41.249.250.101 1723 extendable

ip nat inside source static udp 192.168.1.2 1723 41.249.250.101 1723 extendable

ip nat inside source static tcp 192.168.1.2 4500 41.249.250.101 4500 extendable

ip nat inside source static udp 192.168.1.2 4500 41.249.250.101 4500 extendable

!

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 1 permit 192.168.2.0 0.0.0.255

access-list 23 permit 0.0.0.0 255.255.255.0

access-list 23 permit 192.0.0.0 0.255.255.255

dialer-list 1 protocol ip permit

snmp-server community public RO

!

!

control-plane

!

!

line con 0

login local

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

password ******

login local

transport input telnet

line vty 5 15

access-class 23 in

privilege level 15

password *******

login local

transport input telnet

!

scheduler max-task-time 5000

scheduler allocate 20000 1000

end


routeur1841#


thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mchin345 Thu, 11/13/2008 - 15:05
User Badges:
  • Silver, 250 points or more

Yes this configuration will work. Configure on caller router routing protocols as uninteresting in the interesting traffic definition to prevent periodic hellos from resetting the idle timeout. Since the router uses the interesting traffic definition ONLY to check whether the primary link is active, consider making all IP traffic uninteresting using the command dialer-list number protocol ip deny. With this interesting traffic definition, the idle timeout is never reset, and the router checks the status of the primary link at the specified interval. On the calling router, you do not need to define dynamic routing protocol as uninteresting traffic, as long as the router will not do any dial-out


Actions

This Discussion