Extension Mobility - error in CCM 4.2

Unanswered Question
Nov 7th, 2008

Dear Friends

Problem:We receive an error while we trying to implement the extension mobility feature for a customer.

Here are the details:

-->we have configured the extension mobility for couple of phones as per the procedure (for testing firstly before implementing)

-->then we tried the feature by pressing the services button(IP phone model 7941), then selecting the Extension mobility. Then without even asking for the user id and password it is landing at the following error: Login Unsuccessful error:[2]

steps that we did for trouble shooting this problem:

-->we checked the user id sync from the Active Directory to CCM, by creating a userid in the AD. The userid has got reflected in the CCM(CCM administration->user->global directory)

-->Then we went as per the procedure given by cisco for the bug error:[2] i.e

The Extension Mobility phone login is unsuccessful with the Active Directory because the Password field for all of the application users in the registry is empty.

Solution: Complete these steps to resolve this issue:

1. Select Start > Run, type regedit, and click OK.

2.Check the registry entry for Cisco CallManager Extension Mobility located at HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems Inc.\Directory Configuration\AppUsers\CCMSysUser.

3.Make sure that an entry exists for the Password field, and that the userID is CCMSysUser. If this entry is not there or the entry is wrong, a problem exists with the installation. You can now reset or add a password for this user. Complete these steps to change the CCMSysUser password.

1.Go to C:\dcdsrvr\bin and execute the CCMPWDChanger.exe application.

2.Specify your Active Directory password. At this point you can choose to change the userID (in this case, CCMSysUser) and set a password for this user.

3.Restart the IIS Admin service and the Cisco Tomcat service from Start > Programs > Administrative Tools > Services.

-->After performing these step, still we are getting the same error when trying to login in to the EM.

Pl suggest us on how to proceed further on this issue..

You can reach me @ 99625 14561 for further clarifications or provide your no so that i can call you to explain the prob for your further understanding.



Karthik Sridharan

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Jaime Valencia Fri, 11/07/2008 - 12:49

have you tried restarting the tomcat service??



if this helps, please rate

karthiksr Fri, 11/07/2008 - 23:50

Hi javalenc

Once i did the changes in the password, i have restarted the Tomcat and the IIS admin service in the CCM server(by control pane>admin tools>service)

But still the same issue, i am getting the login unsuccessful error:[2].

Pl suggest on how to proceed...


Karthik Sridharan

99625 14561

karthiksr Tue, 11/11/2008 - 05:56

@Volodymyr Morskyy

Ya... i did that...Still the same prob.


Karthik Sridharan

karthiksr Wed, 11/12/2008 - 04:32

Finally the prob has been solved with the reinstallation of the Application AD plugin.


Karthik Sridharan


This Discussion