Vlan Trunk from Switch to 3845 router with 3 vlans

Answered Question
Nov 7th, 2008

Hi,

I'm kinda confiused here...

I have a port on a switch configured as :

interface GigabitEthernet10/1

description TRUNK VLAN 227 228 238 switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 227,228,238

switchport mode trunk

no ip address

end

The vlan interfaces on the switch are setup and UP-UP.

Now i need to connect this trunk to the router on Fa3/0

Although, I am unsure how to configure the router's Fa3/0 port for all 3 vlans.

I tried setting up sub interfaces on the Fa3/0 as Fa3/0.1 .2 and .3 with encap dot1q and then created the vlans 227 228 and 238 with IP addresses.

The sh int vlan 227 on the router shows:

Vlan227 is up, line protocol is down

Hardware is EtherSVI, address is 0018.b9be.3630 (bia 0018.b9be.3630)

Description: VLAN227

Internet address is 216.24.227.3/24

Why is my vlan not up?

I have this problem too.
0 votes
Correct Answer by shevchiksv about 8 years 1 month ago

first of all add vlan to vlan database, if you haven't done this

second you must put on ip address on subintefaces like this:

interface fa3/0

no ip address

interface fa3/0.227

encapsulation dot1q 227

ip address 216.24.227.3 255.255.255.0

interface fa3/0.228

encapsulation dot1q 228

ip address xxx.xxx.xxx.xxx 255.255.255.xxx

and so on

and NEVER WRITE YOUR PUBLIC IP_ADDRESS!!! :))

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
shevchiksv Fri, 11/07/2008 - 06:25

first of all add vlan to vlan database, if you haven't done this

second you must put on ip address on subintefaces like this:

interface fa3/0

no ip address

interface fa3/0.227

encapsulation dot1q 227

ip address 216.24.227.3 255.255.255.0

interface fa3/0.228

encapsulation dot1q 228

ip address xxx.xxx.xxx.xxx 255.255.255.xxx

and so on

and NEVER WRITE YOUR PUBLIC IP_ADDRESS!!! :))

pipsadmin Fri, 11/07/2008 - 06:38

I got confused... with seting up trunks and switch ports on a router...

I had fergot about the vlan ID on the encapsulation dot1q...

OH ! fergot to remove them,////

Actions

This Discussion