Etherchannel configuration

Answered Question
Nov 8th, 2008
User Badges:

hi, i have the following configuration regarding etherchannel. i want to know that is that interface is in access mode or in trunk mode. what does the command "switchport access vlan 109" has effect on this etherchannel. is it going to forward only vlan 109 traffic to the etherchannel or all vlan traffic will go through this etherchannel


interface TenGigabitEthernet4/3

switchport

switchport access vlan 109

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 2 mode active




interface TenGigabitEthernet4/4

switchport

switchport access vlan 109

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 2 mode active

Correct Answer by Istvan_Rabai about 8 years 8 months ago

It will only take effect if you configure the switchport as access port:


interface TenGig4/3

switchport mode access


Then it will be part of vlan 109.


If you use this interface as a trunk, then the "switchport access vlan 109" is unnecessary.



Cheers:

Istvan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jon Marshall Sat, 11/08/2008 - 08:31
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Should act as a trunk - what is under the port-channel interface - po2.


Easiest way to see what is happening regarding trunking is "sh interface trunk".


Jon

Istvan_Rabai Sun, 11/09/2008 - 19:36
User Badges:
  • Gold, 750 points or more

Hi Waseem,


Agree with Jon.


The "switchport mode trunk" command will determine the mode of operation of the link.


No matter if you configured "switchport access vlan 109".


Cheers:

Istvan

itdsmartnet Sun, 11/09/2008 - 21:55
User Badges:

hi,

Thanks for your reply, what is the effect of switchport access vlan 109. if i remove this command does it matter on configuration.

Thanks

Correct Answer
Istvan_Rabai Sun, 11/09/2008 - 22:20
User Badges:
  • Gold, 750 points or more

It will only take effect if you configure the switchport as access port:


interface TenGig4/3

switchport mode access


Then it will be part of vlan 109.


If you use this interface as a trunk, then the "switchport access vlan 109" is unnecessary.



Cheers:

Istvan

Actions

This Discussion