Rogue QOS markings Fudging simple QoS

Unanswered Question
Nov 8th, 2008

Yeah, on a switch where the users are experiencing intermittant outbound voice quality issues coupled with high jitter readings on the phone, I got the got the attached output from show mls qos interface fas0/47 statistics (one of the trunk ports)..

I see lots of marking done outside of the VoIP QoS paramaters, and I worry that simply trusting-dscp is getting packets priority that shouldnt be getting it, and that priority is high enough to mess with RTP.

Before I go down this road all the way, I was hoping someone would look over the queue-maps and the output of that show command and let me know if this could be the source of the end-users problems.

And if so, what is the best way to distrust/remark packets not coming from phones?

Thanks all.

ps; the only DSCP we want to be seeing is 24 and 46, for SCCP and RTP respectively.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
allan.thomas Sat, 11/08/2008 - 16:01

Ensure that only your IP Phone switchports are configured to trust CoS at the edge, in this instance the PC traffic through phone switchport will be untrusted which is the default.

However, this can be overwritten with the command 'mls qos trust extend [cos value]'. The default is untrusted and CoS 0, Make sure that your IP Phone switchports are not configured with anything else other than 0.

Make sure that you have enabled mls qos priority-queue out the switchports and trunk interfaces, this will ensure that the priority queue is used, and therefore service before others.

Also configure your trunk ports to trust CoS for ingress scheduling.

If your still concerned with the markings, then untrust your switchports and trunks, and configure classification on your inbound Core SVIs using service-policies.

HTH

Allan.

Actions

This Discussion