isdn PRI call disconnect after few minutes

Unanswered Question
Nov 8th, 2008

Hi,


when the call pass through the ISDN PRI, the call get disconnected after 5 minutes.

the scnario is:

CCM - H323 - VG - E1 - PSTN.


VG is configured as below:


!

card type e1 0 0

logging buffered 51200 warnings

enable secret xxx

!

no aaa new-model

!

resource policy

!

network-clock-participate wic 0

network-clock-select 8 E1 0/0/0

!

!

ip cef

!

!

isdn switch-type primary-net5

!

voice-card 0

dspfarm

!

!

voice disc-pi-incoming-on

!

voice service voip

allow-connections h323 to h323

redirect ip2ip

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco

h323

!

!

voice class codec 99

codec preference 1 g711ulaw

codec preference 2 g729br8

codec preference 3 g729r8

!


!

voice translation-rule 1

rule 1 /^403/ //

!

voice translation-rule 2

rule 1 /^66/ /40366/

rule 2 /^67/ /40367/

rule 3 /^4036626/ /4036626/

rule 4 /^4036611/ /4036611/

rule 5 /^4036622/ /4036622/

rule 6 /^.*/ /4036666/

!

!

voice translation-profile in

translate called 1

!

voice translation-profile out

translate calling 2

!

!

!

controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-31

!

class-map match-all voice-traffic

match ip dscp ef

class-map match-all voip-signaling

match ip dscp cs3

!

!


interface GigabitEthernet0/0

description **** TO Firewall ****

ip address 10.10.43.2 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.10.43.2

!


!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!


!

interface Service-Engine1/0

ip unnumbered GigabitEthernet0/0

service-module ip address 10.10.43.13 255.255.255.0

service-module ip default-gateway 10.10.43.2


!

!

voice-port 0/0/0:15

!


dial-peer voice 100 voip

tone ringback alert-no-PI

description connect to IP Phones

destination-pattern 66..

session target ipv4:10.10.41.11

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 6000 voip

description "to cue for voice mail"

destination-pattern 8...

session protocol sipv2

session target ipv4:10.10.43.13

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 6666 voip

description " to cue for AA"

destination-pattern 6767

session protocol sipv2

session target ipv4:10.10.43.13

dtmf-relay h245-alphanumeric h245-signal

codec g711ulaw

no vad

!

dial-peer voice 111 pots

tone ringback alert-no-PI

description from ISDN PRI

translation-profile incoming in

incoming called-number .

direct-inward-dial

port 0/0/0:15

!

dial-peer voice 201 pots

description "outgoing calls to E1 PRI"

destination-pattern T

port 0/0/0:15

forward-digits all

!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jbarcena Mon, 11/10/2008 - 15:06

Could you please take a 'debug isdn q931' and post the output?


Let's take a look to the disconnect reason.


//J

mohamedrishin Wed, 11/12/2008 - 23:51

hi


i have a similar problem but in a single site CME


i am attaching the debug and sh run



all calls are getting disconnected after 30 sec



Attachment: 

Actions

This Discussion