Multicast MOH from HQ to CME over FR connection

Unanswered Question
Nov 9th, 2008
User Badges:

I tried to let CME phnoe to hear M/C MOH from HQ phone but i heared silence

WHY?


I configured M/C audio source with enable M/C

MOH server support M/C

MRG support M/C

Put audio file & MRG to HQ phone.

enable " ip multicast-routing" & "ip pim dense-mode" along the path.


Anything I should make else??

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
allan.thomas Sun, 11/09/2008 - 14:01
User Badges:
  • Blue, 1500 points or more

With CME it is not necessary to stream or Multicast the audio-source across the WAN. You should provision MMoH from the flash on gateway, this will preserve you bandwidth, especially when you are using FR. It does not require ip multicast-routing to be configured.


There is a music-on-hold.au file located in the appropriate CME archive file which you would have extracted onto the gateway. Check your flash for this file, if not open the archive and tftp it onto the flash.


Under the telephony-service you will only need to add the following commands:-


Telephony-service

moh music-on-hold.au

multicast moh port route x.x.x.x x.x.x.x


The multicast command simply identifies the base address and port for the MMoH, and the route stipluates which ipaddress/interface MoH will be forwarded through. This should be the fastethernet i/f or sub-if for your voice-vlan.


HTH

Allan.


youssef.ahmed Sun, 11/09/2008 - 22:01
User Badges:

Thx for reply,


I think you talk about SRST case with typical conf. like CCM.But in CME I think the case is different.

I think CME is an independant system not like SRST.

Also I tried your suggestion but with no luck.

Correct me if I wrong.


allan.thomas Mon, 11/10/2008 - 01:03
User Badges:
  • Blue, 1500 points or more

Hi Ahmed, can you please clarify your how you have deployed the IP Phones at the remote office.


As you have quite rightly stated CME is an independant system, therefore there should be no dependencies on CUCM.


However, you mentioned that you have configured MRG and enabled Multicast on the audio-source. This will only work if the IP Phones at the remote office are registered to CUCM and have the appropriate MRGL defined and the Media-stream service is activated and running.


With CME the IP Phones at the remote office should be registered to the CME gateway and not CUCM.


Please can you post the configuration of your gateway.


Thanks

Allan

youssef.ahmed Mon, 11/10/2008 - 01:16
User Badges:

If HQ phone put CME phone on hold & HQ configured as multicat ,i think CME user should hear HQ moh file not CME moh flash file,right??


Anyhow,here is my conf. as attachment:





Attachment: 
florian.kroessbacher Mon, 11/10/2008 - 02:08
User Badges:

Hy Ahmed,


what is your CuCM config.


Our MRG is the First MOH server included.


MOH Server Configuration (CuCM)


This runs on the following

IP:239.1.1.1

Base Multicast Port Number: 16384

and runs the Files SampleAudioSource.wav with 2 max Hops


So our Branch config is like this


moh SampleAudioSource.ALAW.wav

multicast moh 239.1.1.1 port 16384 route Fastethernet Loopback


Because our H323 Interface is bounded on the Loopback

Marwan ALshawi Sun, 11/30/2008 - 02:40
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

can u add the folliwng command


in global config mode


ccm-manager music-on-hold


also make sure that the multicast address same to ur cucm of moh server


by the way if u have a switch in ur LAN and the switch do the intervaln routing make sure that switch support multicasting


good luck

Actions

This Discussion