VRF Enabled Service-Engine Interface for CUE

Unanswered Question
Nov 9th, 2008

Has anyone been able to successfully configure and TEST vrf enabled service-engine interface?. This is for CUE.

The option to configure vrf is there i.e.

service-enginer 1/0

vrf forwarding CUST-A



but once enabled I am told voicemail stops working.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 1 (1 ratings)
beavisthrare1 Wed, 07/15/2009 - 06:26

I know this is an old post, but I am trying to get the same exact scenario to work. Has anyone been successful in getting a service module running CUE to work with VRF??

Nicholas Matthews Wed, 07/15/2009 - 06:33

CUE is still not VRF aware, no. But you can get the vrf on the service engine:

voice vrf vrf2

ip vrf vrf2

rd 100:2

route-target export 100:2

route-target import 100:2

interface Service-Engine1/0 ip vrf forwarding vrf2

ip address service-module ip address

service-module ip default-gateway



beavisthrare1 Wed, 07/15/2009 - 07:01

Thanks for the quick response, Nick.

Here's the config from my router. When I attempt to add the 'voice vrf BEP', I get, ' % Cannot configure/unconfigure the CLI when VoIP services are running or when active VoIP calls are present'. There are no calls currently active, so what would I need to do to get around this?

Also, on the service engine, if I try to configure the IP address directly, it tells me it conflicts with Gig0/1, which is on the same subnet.

Any help is greatly appreciated!


AJAZ NAWAZ Wed, 07/15/2009 - 07:06

I would imagine you'd have to shut down you service-engine interface...

or go furter. shutdown all interfaces and remember that you will have to re-apply your IP addrs after you enable vrf under each applicable interface.

let's see.


beavisthrare1 Wed, 07/15/2009 - 07:14

Yes, I had tried shutting down the voip service and it let me add the voice vrf BEP. See attachment for the latest config. I'm still missing something as I can't get to the service module. Any suggestions?

Nicholas Matthews Wed, 07/15/2009 - 07:53

Things look right, just make sure you're on 124-24T or later and this looks like it should work provided your VRF routing is in order.



This Discussion