Calendar server may be down showing in IP Phone Messenger

Unanswered Question
Nov 9th, 2008
User Badges:

When i select Today's Meeting from IP Phone Messenger its showing "Query Operation Failed: The Calendar Server may be down......" I've checked the configuration but it seems to be ok bcz when i run System>Troubleshooter its showing all Test passed even Microsoft Exchange Trusted Certificate is loaded.Please help me in this....


CUPS Version : 6.0.2.1000-27


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (4 ratings)
Loading.
gogasca Sun, 11/09/2008 - 17:11
User Badges:
  • Green, 3000 points or more

Which type of certificate you guys are using?

1. Third party (Godady, Verisign)

2. MS certificate?


Under Exchange | Gateway make sure it matches proper values, could you please upload:

1. your root cert and the Exchange cert.

2. Screenshot of Presence Gateway config

a.gooding Thu, 02/05/2009 - 09:09
User Badges:
  • Bronze, 100 points or more

did you guys ever resolve this. im at the same point where it states calendar server down and i "think" ive done the correct steps


thanks

htluo Thu, 02/05/2009 - 10:20
User Badges:
  • Red, 2250 points or more

Please note:


1) Troubleshooter will NOT tell you if Calendar integration is good or not. Not that intelligent yet.


2) The message you're seeing has nothing to do with calendar, even though it mentioned about Calendar Server.


Go to CUPS Admin > Application > Meeting Notification > Settings. If you have a meetingplace server, enter the meetingplace IP address. Port 80 should be fine. If you do not have meetingplace server, enter Exchange OWA IP address here. use port 443.


The deal is: if this setting is blank, you'll get "calendar server down" message.


For more information see:

http://www.lulu.com/content/5552336


And http://htluo.blogspot.com/


Michael

a.gooding Thu, 02/05/2009 - 10:48
User Badges:
  • Bronze, 100 points or more

hi there


thanks a lot for the info. tried that but still giving the same error. its my first time trying this out so im a little lost as to the exact steps. do i need to do anything on the LCS side?


IPPM is working, can get contacts and broadcast messages


PS dont have meeting place so used the ip of the OWA as you advised. i also restarted the presence engine but same error.


thanks again for any advise.


note too that i have presence and MOC working together and can see each other's status etc. i can also access the calendar via the account i created


ive also been reading your stuff previous to this. needless to say its great


also getting the following error


The MeetingPlace Certificate file is either not currently loaded or there is a subject CN (Common Name) mismatch. This Certificate is required for the MeetingPlace Join callback feature to work properly

htluo Thu, 02/05/2009 - 13:56
User Badges:
  • Red, 2250 points or more

by looking at your screenshots, it looks like you got the wrong certificate uploaded.


you should upload the CA (issuer) cert instead of the end-entity (exchange) cert.


Michael

a.gooding Thu, 02/05/2009 - 16:59
User Badges:
  • Bronze, 100 points or more

i know its a pain but still no dice. That's not my screenshots by the way. ive setup a lab so ill try it out and see if i can do some reading and figure this out.


thanks anyway

htluo Thu, 02/05/2009 - 17:10
User Badges:
  • Red, 2250 points or more

last resort: open a TAC case and ask for Michael Luo :)


Currently, I'll be on call from 12:45pm to 3:45pm CST.


Michael

a.gooding Fri, 02/13/2009 - 03:44
User Badges:
  • Bronze, 100 points or more

Guys


after doing this over a few times im 90 % there. my issue was i was doing the certificates incorrectly. im now able to see the meetings coming up.


two issues though


1. time is wrong on the meetings - in OWA it is correct, NTP is working so not too sure what it is


2. when i try to reply to the meeting i get the following


Invalid Message Identifier

You were trying to reply to a message that had been deleted from the EPAS server.

htluo Fri, 02/13/2009 - 05:49
User Badges:
  • Red, 2250 points or more

1. check time settings on CUPS by using command "utils ntp status"


2. In order to "reply to the meeting", a meetingplace server has to be configured properly.


Michael

a.gooding Fri, 02/13/2009 - 07:40
User Badges:
  • Bronze, 100 points or more

thanks for the reply.


therefore, for me to "reply to the meeting" i must have a meetingplace server? i configured the notification setting to be that of the LCS server. therefore, if i do NOT have a meetingplace server, the only thing i can do is see the meeting request on the phone but i cant do anything other than that?


thanks for your replies thus far im slowly understanding the system :)

a.gooding Mon, 02/16/2009 - 12:11
User Badges:
  • Bronze, 100 points or more

is it me or is the documentation a little on the general side.


i just need two questions answered


1. do i install CA on the exchange - this is the only way im getting it to work (note i dont fully grasp the certificate stuff with this so excuse my ignorance).


2. do i need to meeting place server to have notification? - might seem like an obviously dumb question but im going out on a ledge to still ask :)


htluo Mon, 02/16/2009 - 14:07
User Badges:
  • Red, 2250 points or more

1. All you need is a certificate on the OWA server. It doesn't matter where/how you got that certificate. It could be obtained from external CA, internal CA or self-signed. A certificate is just a flat file.


2. You don't need meeting place to have notification. But you won't be able to do anything to the notification without meetingplace.


Michael

a.gooding Mon, 02/16/2009 - 14:37
User Badges:
  • Bronze, 100 points or more

i think this is the most amount of questions ive asked thus far.


OWA already had a certificate but i could only get the integration to work when i enabled CA on the OWA server, downloaded the root certificated and loaded on the presence. if i downloaded and installed the root certificate from our normal domain controller i couldnt get it working. hence my confusion as to whats the difference.


as for the second one, thanks i know you said that before, just wanted to be clear. and this is meeting place NOT meeting place express or VT correct?

htluo Mon, 02/16/2009 - 15:41
User Badges:
  • Red, 2250 points or more

The CUPS server needs to trust the issuer of the certificate.


If the OWA cert was issued by the domain controller, you can install the root cert from the DC and make it worked.


Michael

a.gooding Mon, 02/16/2009 - 17:45
User Badges:
  • Bronze, 100 points or more

Michael,


youve been a ton of help, thanks so very much. ill verify the certificate issue and take it from there. hopefully i wont have to post any more.

Actions

This Discussion