BGP to EIGRP redistribution

Unanswered Question
Nov 9th, 2008

Hello. I have an EBGP link to my ISP from my ISP router. Internally Im running EIGRP. I have a 10. network and internally I have several vlans configured on a dist switch. Example.

VLAN 101 - 10.254.30.128/25

Vlan 102 - 10.44.80.0/24

VLAN 103 - 10.44.81.0/24

etc

My first question is, on this dist switch, using EIGRP, if I configure network 10.0.0.0 and then include the no auto-summary command, will it give me all the granular routes in the routing table? If so, what is the benefit of configuring all these networks line by line in internal BGP (on the ISP facing router) and then redistributing them into EIGRP. example

Router bgp 64557

network 10.254.30.128 mask 255.255.255.128

network 10.44.80.0 mask 255.255.255.0

network 10.44.81.0 mask 255.255.255.0

router eigrp 64557

redistribute bgp 64687 metric 100000 1000 255 1 1500

network 10.0.0.0

no auto-summary

My question is why redistribute from BGP to EIGRP? Why not let EIGRP learn to internal network, then redistribute its routes into BGP?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Jon Marshall Sun, 11/09/2008 - 08:07

Wale

Your question about EIGRP - yes if you just 10.0.0.0 and make sure you turn off auto-summary you will see all the EIGRP routes in the routing table.

I may have misunderstood this next bit but when you add this to your configuration

router bgp 64557

network 10.254.30.128 mask 255.255.255.128

network 10.44.80.0 mask 255.255.255.0

network 10.44.81.0 mask 255.255.255.0

this is not so you can redistribute these networks into EIGRP, it is so you can advertise these networks to your EBGP peer. So the question is do you want to advertise these networks to your ISP ?

The reason for redistributing from BGP to EIGRP is that any routes learnt from your EBGP peer would not get into your routing tables. Alernatively you could just have a default-route in your internal routing tables pointing to your EBGP router and not bother redistributing into EIGRP ie. you may not want all BGP routes from your ISP especially if you only have path out of your network.

And yes you could if you wanted redistribute EIGRP into BGP if you wanted but using the network statement gives you more control of which networks you advertise to your ISP.

Jon

west33637 Sun, 11/09/2008 - 09:48

Hello Jon, thx for the response. It was very helpful.

I have one more question.

I have the ff partial config output from my ISP facing router below specifying the ISP as the default route. could you explain this configuration and why it would not be better to just configure the prefix-list- ip prefix-list DEFAULT_IN seq 10 permit 0.0.0.0/0, attach it to the ISP neighbor (10.250.20.2)inbound, and then add statement- ip route 0.0.0.0 0.0.0.0 10.250.20.2 on the dist switch. maybe there is some merit to the below technique that I don't understand. could you help make more sense of this? Thanks

ip prefix-list Advertise_Default seq 5 permit 0.0.0.0/0

ip prefix-list DEFAULT_IN seq 10 permit 0.0.0.0/0

route-map BGP_to_EIGRP permit 10

match ip address prefix-list Advertise_Default

router bgp 64557

neighbor 10.250.20.2 remote-as 65599 ---- ISP

neighbor 10.250.20.2 prefix-list DEFAULT_IN in

router eigrp 64557

redistribute bgp 64557 metric 100000 1000 255 1 1500 route-map BGP_to_EIGRP

Jon Marshall Sun, 11/09/2008 - 10:25

Wale

The config you provided is basically filtering out all routes except the default-route from your ISP and then redistributing this into your internal EIGRP process.

To be honest if you only have one path out of your network then it is questionable as to why you need BGP at all. I appreciate that some ISP's mandate using BGP or at least they do for MPLS in this country (UK) but it is extra configuration if you don't need it. As previously suggested you only really need a default-route pointing to your router that connects to the ISP but then the ISP may well rely on your BGP advertising your internal networks.

If you configured a default-route on the distribution switch then you would not need to redistribute BGP into your EIGRP process at all so you could remove all ip prefix-list configuration.

Note that your default-route on your distribution switch would have a next-hop of the internal interface of your BGP speaking router and not the next-hop of your ISP - 10.250.20.2.

Having said all that there is nothing inherently wrong with using the config you have and if you are comfortable with BGP/EIGRP then you should be fine.

Jon

west33637 Sun, 11/09/2008 - 11:55

Thx Jon. We are actually connecting to 2 different ISPs on 2 different routers linked via IBGP. upon looking at our set up, it actually makes more sense now why we are redistributing the default route from the ISP into EIGRP. I will play around with the default routes when I get on my home lab to see which method works best. Thanks a million!

Actions

This Discussion