Remote site IP Phone Lag and Gateway Troubles

Unanswered Question
Nov 9th, 2008

At site #1 we have a CUCM and a Voice Gateway, the gateway is a 2811 and is acting as the voice gateway as well as the VPN/Internet termination device. The tunnel to the remote sites is created from that 2811.

At site #2 there is a 2651XM terminating the internet and tunnell, but it is not working as a gateway.

The telephones at site 2 have 2 problems that are very strange

1) When the phones ring at that site, when you press Answer, there is a 2 second delay between the time they press answer and the time the speech path is created between the 2 phones

2) When a call is sent from the PSTN gateway to the remote telephone (say when unity transferrs a call to that user) the person presses answer and the call is just dropped (Fast busy to the caller). The gateway is setup as H.323 and I have bound the H.323 process to the INSIDE address.

The weird delay gets me because once the call is actually setup (G.711) the call sounds perfect, I spoke for 10 minutes with the remote end and didn't lose a single packet, MOS scores of 4.3 or better and the call was perfect which leads me to believe the VPN performance is good enough for bearer traffic, control traffic should be just fine.

update: For a laugh I enabled the MTP on the gateway in CUCM, I am using a hardware MTP in the 2811. When I do that, the PSTN calls are now flowing properly to the remote side in regards to bearer traffic -- delays obviously are still there.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gogasca Sun, 11/09/2008 - 16:34

1. If its IP Phone to IP Phone,

CCM detailed trace will be first step to check if there is a delay introduced in media negotiation before we send StartMedia Transmission to Phone after recieving the Answer.

Do you use this value under VPN?

ip tcp adjust-mss X

2. Same thing, CUCM traces, please include CUCM version, Unity and TSP version.

Phone load and configuration for devices involved, here you can try to change Supervised transfer to see if makes any difference

Traces and simultaneous sniffer captures will tell us what exactly is happening.

Please open up a TAC case so that we can look more closely at the details of your setup in a less public forum.

justincohen Sun, 11/09/2008 - 19:58

Not possible to open a TAC case really, as we are doing this with our demo gear in the lab.

Taking voicemail out of the picture, did more testing, and the far end tells me (this is ip phone to ip phone) when the phone rings and they press ANSWER, it rings another 2 times before the phone actually answers.

It's funny you mention the IP TCP ADJUST-MSS because yes, I do have that on the Dialer1 interface used to connect to the internet. It is set to ip tcp adjust-mss 1400

Actions

This Discussion