PortChannel and trunking

Unanswered Question
Nov 9th, 2008

Hi guys,

Before I start just wanted to say that this is a great forum! Most useful I have found to date for Cisco!

I have a quick question regarding PortChannels and trunking.

In our environment I have several access layer switches that connect to the core switch (stack of four 3750's) using PortChannels.

Typically if I use a 3560 as an example, we have four interfaces combined into a PortChannel to give us 4Gbps from the switch to the core. I have reviewed the configuration and have found inconsistencies in the configuration of the PortChannels. On some port channels the command 'switchport mode trunk' is defined, whilst on others this is not the case? The four interfaces that make up the channel also have this defined (as you would expecext). What issues would arise from / from not having this defined on the PortChannel (please see below for an example)

SW001#sh run int po7

Building configuration...

Current configuration : 96 bytes

!

interface Port-channel7

description TRUNK TO SW003

duplex full

flowcontrol receive on

end

SW003#sh run int po1

Building configuration...

Current configuration : 92 bytes

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

end

What should I have defined in the channel configuration? I have standardised most of the interfaces so they read like below

SW003#sh run int g 0/49

Building configuration...

Current configuration : 226 bytes

!

interface GigabitEthernet0/49

description SW001 Gi 1/0/51 FSR2-1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

spanning-tree link-type point-to-point

end

Thanks

Darren

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Istvan_Rabai Sun, 11/09/2008 - 19:50

Hi Darren,

This is good that you have standardised the link configs.

I would standardise the non-standard interfaces as well and the I would recreate the port-channels based on them (out of working hours of course).

This would insure that the port-channel configs are consistent throughout your network.

Cheers:

Istvan

darren-carr Sun, 11/09/2008 - 19:55

Hi Istvan,

Thanks for the feedback.

How would you define the PortChannels? i.e what would you specify for the configuration if the ports that make up the channel have been assigned to a channel group, configured with LACP, etc?

Would you define the encapsulation, etc? or should the channel be able to negotiate this itself based on the config of the ports that make up the channel.

Please see below for a typical portchannel config in our environment

SW003#sh run int po1

Building configuration...

Current configuration : 92 bytes

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

end

Istvan_Rabai Sun, 11/09/2008 - 20:18

Hi Darren

When you configure the "channel-group 1 mode active" command for the first time on any interface, the IOS will create the Port-channel 1 (Po1) interface with the same configuration as the physical interface.

When you add subsequent links to the port-channel, make sure these have the same configs as the first link and the Port-channel interface.

Otherwise you will get inconsistency errors.

You should configure the respective configurations on the other side of the channel, of course, so the channel can be negotiated.

Cheers:

Istvan

darren-carr Sun, 11/09/2008 - 20:26

Hi Istvan,

So given that on my stack for this I already have a portchannel 'PortChannel 6', I should first of all ensure that the interfaces G x/x are configured correctly with the channel protocol, speed, etc

I should then remove the PortChannel 6 and then add it again?

Im a bit confused as to what the next step is?

What I was hoping was that I could first of all define the interfaces consistently that make up the channel and then configure the portchannel (in this case Portchannel 6) without having to recreate it again?

In doing this I was unsure about what configuration I should apply to the port channel given that the four ports that will make up the channel have been configured correctly using LACP, etc.

I guess what I am asking is how should I define the configuration of the port channel? Should I enable trunking, encapsulation, etc? I appreciate I need to confirm the interface configuration at both ends to ensure that there is consistency I just want to confirm what I need to have enabled on the port channel. As it is the current port channel has trunking enabled, 802.1q encapsulation and that is it!

Will this suffice?

Thanks and I hope this makes sense?

Darren

darren-carr Sun, 11/09/2008 - 20:29

Istvan

Here is the config from both switches for the respective portchannel... hope this helps to explain what I am trying to define

Switch 1

SW001#sh run int po6

Building configuration...

Current configuration : 180 bytes

!

interface Port-channel6

description TRUNK TO SW004

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,70

switchport mode trunk

flowcontrol receive on

end

Switch 4

SW004#sh run int po1

Building configuration...

Current configuration : 128 bytes

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,70

switchport mode trunk

end

Thanks

Darren

darren-carr Sun, 11/09/2008 - 21:12

Also,

Is it necessary to specify

switchport trunk encapsulation dot1q

switchport trunk

If they are already defined on the interfaces that will make up the channel group?

Some docs I read specify that the port channel can group the interfaces it recognises automatically into the channel group?

I'm just looking to remove any unecessary lines of configuration from my switches.

Thanks

Istvan_Rabai Sun, 11/09/2008 - 22:18

On the Port-channel interface it isn't necessary to specify these commands. IOS will configure the Port-channel interface automatically, as soon as the commands are consistent on all interfaces that make up the channel group.

Cheers:

Istvan

darren-carr Sun, 11/09/2008 - 22:21

Hi Istvan,

Thanks very much for the information, I will make the changes out of hours this coming weekend.

Best regards

Darren

Actions

This Discussion