OSPF with MPLS backup

Unanswered Question
Nov 10th, 2008
User Badges:


Hi,


I have configured the following on untrusted router which is having Primary and back up MPLS link to the 10.51.38.1 ( primary link)


and 10.52.38.1 ( back up link) network .



Scenario




10.50.38.0/24 --Internal network


10.50.38.1 -Router E0 (Default gateway)


10.51.38.0/30- External- Primary MPLS link


10.52.38.0/30 - External- secondary MPLS link


configuration


Interface fa3/0


ip address 10.51.38.2 255.255.255.252

no ip proxy-arp

ip nat outside

ip virtual-reassembly

ip ospf network broadcast

ip ospf cost 1

ip ospf pririty 0

ip ospf mtu-ignore


duplex auto

speed auto

no shut


interface fa3/1

ip address 10.52.38.2 255.255.255.252 --

no ip proxy-arp

ip nat outside

ip virtual-reassembly

ip ospf network broadcast

ip ospf cost 10

ip ospf pririty 0

ip ospf mtu-ignore

duplex auto

speed auto

no shut


router ospf 150

log-adjacency-changes

network 10.50.38.1 0.0.0.0 area 10

network 10.51.38.0 0.0.0.3 area 10

network 10.52.38.0 0.0.0.3 area 10


My question is


1) Does it work ?

2) If yes is this correct method ?


3) what will happen when primary link fail ?


thanks in advance

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Mon, 11/10/2008 - 01:29
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Hashim,

1) if the MPLS service is a L2 service your configuration should work.

You should configure in the same way at the other(s) site(s) so that all of them agree on the primary cloud / link

2) This is a legimitate configuration if you want to use only one link and the other is a cold backup. If you want to use both just let unchanged OSPF costs.


3) when the primary link fails the router will detect failure of the link, the OSPF neighbor will be declared dead within dead-interval seconds, after 5 seconds the SPF is executed, all prefixes are now reached via backup link

the convergence time is up to 46 seconds with default timers settings.

You can speed using :

i) OSPF fast-hellos under second frequency

ii ) or by using BFD (Bidirectional forwarding detection)


Hope to help

Giuseppe





hashim.mp Mon, 11/10/2008 - 22:17
User Badges:

thanks Giuseppe, i have to test this.Do you have any other working configuration on this scenario ?

regards,

Hashim

Actions

This Discussion