iPhone 2.1 VPN & DNS

Unanswered Question
Nov 10th, 2008
User Badges:
  • Bronze, 100 points or more

Interesting problem...


When using the iPhone 2.1 VPN client, I can connect just find and hit everything by IP, however can't pull up anything using the DNS name.


When using the client from a Mac or PC, everything works just fine.


Any ideas on this one?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
patwill66_2 Tue, 11/11/2008 - 09:30
User Badges:

I have this same issue. The iPhone says it supports split tunnel DNS but I have not been able to get it to work. Even with the FQDN for the tunneled traffic, I havent had any luck.

johnnylingo Tue, 11/18/2008 - 14:12
User Badges:
  • Bronze, 100 points or more

That's strange. I found on another forum that you can work around it by doing Split DNS. Tried that and it worked just dandy.


Just put something like this in the Group Policy Attributes:


default-domain value xyz.com

split-dns value xyz.com


patwill66_2 Thu, 11/20/2008 - 11:54
User Badges:

I already have the default-domain value in there so I added the split-dns value command with the list of my internal domains but that didnt help. I tested with a PC as well and it didnt make a difference with the added split-dns list.

johnnylingo Wed, 11/26/2008 - 11:19
User Badges:
  • Bronze, 100 points or more

iPhone 2.2 firmware seems to fix this.

Actions

This Discussion