Help with QOS configuration

Unanswered Question
Nov 10th, 2008
User Badges:

Hello,


1) I have Snom phones that show them using DSCP CS 5 (0x28) on captures.


2) Asterisk servers showing DSCP AF31-low (0x1a)


I have the following configuration for my Cisco 2560 switches;


#Access-list with Snom SIP & RTP

ip access-list extended voip-traff

permit udp any any range 5060 5061

permit udp any any range 10000 20000


#class-map named ipphone & match acl voip-traff:

class-map match-any ipphone

match access-group name voip-traff


#Policy map named voip, match class-map iphone:

policy-map voip

class ipphone

set dscp cs5


#set interfaces to police policy-map voip:

interface-range gi 0/1 - 48

service-policy input voip


#enable qos globally:

mls qos

#qos on 4500


#map out QOS to COS-DSCP

mls qos map cos-dscp 0 8 16 24 32 46 48 56


My question is can I do a packet re-write and change the DSCP to Expedited Fwdg and if so, how?


Thanks!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Brandon Buffin Mon, 11/10/2008 - 12:45
User Badges:
  • Purple, 4500 points or more

Yes, you can change your configuration slightly to accomplish this. See the following example.


ip access-list extended voip-sig

permit udp any any range 5060 5061


ip access-list extended voip-media

permit udp any any range 10000 20000


class-map match-any ipphone-sig

match access-group name voip-sig


class-map match-any ipphone-media

match access-group name voip-media


policy-map voip

class ipphone-sig

set dscp cs5

class ipphone-media

set dscp ef


This would set the DSCP for signalling traffic to CS5 and media to EF. You could obviously change the signalling as well. Cisco recommends CS3 for signalling.


Hope this helps. If so, please rate the post.


Brandon

jonesm111 Mon, 11/10/2008 - 13:19
User Badges:

Thanks Brandon!


I'm still trying to figure this one out though..


mls qos map cos-dscp 0 8 16 24 32 46 48 56


What does it do?

Brandon Buffin Mon, 11/10/2008 - 13:25
User Badges:
  • Purple, 4500 points or more

This command changes the default Class of Service to DSCP map. An incoming packet with a COS value gets mapped to a DSCP value. The problem is that the default map does not map these values correctly. I'm not sure why Cisco doesn't change the default map, but they haven't. For example, voice traffic with a COS of 5 should map to DSCP value 46 (EF). This is why the command is necessary. Also, see the following link.


http://www.cisco.com/en/US/docs/ios/qos/command/reference/qos_m2.html#wp1012528


Hope this helps.


Brandon

Actions

This Discussion