mtp2 not stable

Unanswered Question
Nov 11th, 2008

we are configuring ss7 on PGW2200 with cisco AS5400 , mtp2 is not stable or flaping attached is debug file taken by terminal mon.

any help on this

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
sbilgi Wed, 11/19/2008 - 15:26

For the troubleshooting this command may help you :

To trace backhaul Signaling System 7 (SS7) Message Transfer Part Level 2 (MTP2 ) message signaling units (MSUs), enter thedebug ss7 mtp2 command in global configuration mode during a low-traffic period. To disable debugging output, use the noform of this command.

debug ss7 mtp2 [aerm | backhaul | cong | iac | lsc | lssu | msu | packet [all] | rcv | suerm | timer | txc][channel]

no debug ss7 mtp2


(Optional) Initiates alignment Error Rate Monitor events.


(Optional) Initiates trace backhaul control messages. The channel argument represents a logical channel number. Valid values are from 0 to 3.


(Optional) Initiates congestion Control events.


(Optional) Initiates initial Alignment Control events.


(Optional) Initiates Link State Control events.


(Optional) Initiates trace backhaul LSSU messages.


(Optional) Initiates trace backhaul MSU messages (use during low traffic only).

packet [all]

(Optional) Initiates low-level MTP2 packet tracing. If you do not specify a channel number or enter the all keyword, the command displays information for channel 0.


(Optional) Displays information about SS7 MTP2 receiver state machine events and transitions.


(Optional) Displays information about SS7 MTP2 Signal Unit Error Rate Monitor (SUERM) state machine events and transitions.

anikas Mon, 03/16/2009 - 13:12

Here is the key message in your log.

*Jan 4 23:33:11.360: MTP2: send LSC Ind ch=0 event=0x6-protocol error cause=0x2

Normally this is due to a mismatch in the following:



Network Indicator


Please verify that they are all the same on both sides of the link.

The best way to verify this is to check with the far end and see what

they expect.

sohail-khan Wed, 03/18/2009 - 00:58

thanks for reply yes we resloved issued few weeks back it was Network indicator not correct on our side.


anikas Fri, 03/20/2009 - 12:59

I am glad that it was resolved. These are the most common causes of these issues.


This Discussion