Cisco CME GUI New Extension & New Phone Issue

Unanswered Question
Nov 11th, 2008

Hi all, I have successfully installed CME GUI on my 2800 router and am able to navigate to the HTTP site (ccme.html), however, I am having trouble adding phones and extensions.

I have a DHCP server setup on the 2800 on its Voice VLAN and the phone has received an IP address, however, when I click "Add Extension" in the CME GUI, I get a "No extensions found" error. Also, when I click on the Add Phone button, I get a "No new phone to add" error.

I have enabled the "auto-reg-ephone" command as the following guide suggests - http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/gui/user/guide/cmegui_user.pdf - however that has not resolved the issue.

The IP Phone that I am using is a Cisco 3911 VoIP phone.

If anyone has any advice it would be much appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
shrutid22 Tue, 11/11/2008 - 20:58

Hello

Connect the phone to the network, then you will be able to add it

and after adding the phone, it will ask u do you want to assign a number click yes and you will be able add a new DN

HTH

voiper_99 Tue, 11/11/2008 - 21:05

Hi, the phone is connected to the network. I have the 2811 connected to a 2960 which is connected to the 3911 (and providing it power via PoE).

The port between the 2811 and 2960 is configured as a trunk (and the 2811 has sub interfaces for each VLAN). The phone is in VLAN 100 and recieves an IP address from the DHCP pool on the 2811 and I am also able to ping the phone from the 2811.

In regards to the licenses for CME and the 3911, are they installed by default or do I have to manually install them?

shrutid22 Tue, 11/11/2008 - 21:23

Hi

Is the phone getting IP address? is it trying to register to CME? Has it downloaded the Load via TFTP?

Have you uploaded the load on to CME?

after you upload the firmware files in the telephony service config you need to run a command

load 3911 xxxx (where xxx is the load file name)

then you need to create cnf which will create the config file per phone

Let me know if this helps

voiper_99 Tue, 11/11/2008 - 21:38

Q. Is the phone getting IP address?

A. Yes

Q. Is it trying to register to CME?

A. I'm not too sure, but when I issue the "show ephone attempted-registrations" command, nothing comes up

Q. Has it downloaded the Load via TFTP?

A. I don't believe so

Q. Have you uploaded the load on to CME?

A. Yes

- You need to run a command

load 3911 xxxx (where xxx is the load file name) - There doesn't seem to be an option to do that -

Router(config-telephony)#load ?

12SP 12SP+ and 30VIP phones

7902 Cisco IP Phone 7902

7905 Cisco IP Phone 7905

7906 Cisco IP Phone 7906

7910 Cisco IP Phone 7910

7911 Cisco IP Phone 7911

7912 Cisco IP Phone 7912

7914 Cisco IP Phone 7914 14-Button Line Expansion Module

7915-12 Cisco IP Phone 7915 12-Button Line Expansion Module

7915-24 Cisco IP Phone 7915 24-Button Line Expansion Module

7916-12 Cisco IP Phone 7916 12-Button Line Expansion Module

7916-24 Cisco IP Phone 7916 24-Button Line Expansion Module

7920 Cisco IP Phone 7920

7921 Cisco IP Phone 7921

7925 Cisco IP Phone 7925

7931 Cisco IP Phone 7931

7935 Cisco IP Conference Station 7935

7936 Cisco IP Phone 7936

7937 Cisco IP Conference Station 7937

7941 Cisco IP Phone 7941

7941GE Cisco IP Phone 7941GE

7942 Cisco IP Phone 7942

7945 Cisco IP Phone 7945

7960-7940 Cisco IP Phone 7940/7960

7961 Cisco IP Phone 7961

7961GE Cisco IP Phone 7961GE

7962 Cisco IP Phone 7962

7965 Cisco IP Phone 7965

7970 Cisco IP Phone 7970

7971 Cisco IP Phone 7971

7975 Cisco IP Phone 7975

7985 Cisco IP Phone 7985

ata ATA phone emulation for analog phone

- You need to create cnf which will create the config file per phone

Q. How do I do this?

By the way, I have just logged in to the phone and I believe it is looking for the files you mentioned above - XMLDefault.cnf.xml and SEP001AA48F751A.cnf.xml

shrutid22 Tue, 11/11/2008 - 21:54

Okay

Now we know whats the problem. There is no 3911/3951 phone firmware loaded on your CME.

Please check the compitable firmware, download from Cisco website and then load it.

How do you do that?

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/command/reference/cme_l1ht.html#wp1033537

Check load (voice register global)

after this go to voice register global and then follow

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmefiles.html#wp1023156

SIP: Generating Configuration Profiles for SIP Phones

check this, it will help you create the phoneload files

HTH

voiper_99 Thu, 11/13/2008 - 15:41

Sorry for not replying sooner, I was unavailable yesterday.

- There is no 3911/3951 phone firmware loaded on your CME

* I think you are correct, the firmware that I had was "SIP3951.8-1-1b.loads" , however, when I look at the compatibility matrix, it is saying I need "SIP3951.8-1-1.loads" - I will try loading that firmware and see if that resolves the issue, however I will be out of the office for most of today but I will definitely let you know the results once I have given the above a try.

Thank you very much for your assitance and the above links.

voiper_99 Thu, 11/13/2008 - 19:42

I tried to locate "SIP3951.8-1-1.loads", however, I was unsuccessful. I am assuming it got re built which is why I've got "SIP3951.8-1-1b.loads" - (I got my firmware from the cme-124-20T.zip

CME 7.0/4.3 files for IOS 12.4(20)T releases package).

So it would appear that I may have the correct firmware after all, however, I don't see why I can't load it. Do you have any other suggestions?

voiper_99 Thu, 11/13/2008 - 21:12

My apologies, I was originally trying to load the firmware with the "voice register global" command, however, when I used the voice register global" command, it worked. Thank you for your assistance.

The phone is still looking for an xml configuration file, can this be created through CME or does it have to be done via CLI?

Actions

This Discussion