Add a C3750G-48TS to a C3750G-24T stack...

Unanswered Question
Nov 12th, 2008

Hi all,

I added a C3750G-48TS to a stack of two C3750G-24T switches.

The new one is running IOS c3750-ipbase-mz.122-35.SE5

The two older ones are running IOS c3750-ipbase-mz.122-25.SEB4.

After I plugged the stack cable I got the following message:

Nov 12 13:45:09: %STACKMGR-6-STACK_LINK_CHANGE: Stack Port 1 Switch 1 has changed to state UP

Nov 12 13:45:09: %STACKMGR-6-STACK_LINK_CHANGE: Stack Port 2 Switch 2 has changed to state

Nov 12 13:45:14: %STACKMGR-6-SWITCH_ADDED_VM: Switch 3 has been ADDED to the stack (VERSION_MISMATCH)

Nov 12 13:45:14: %STACKMGR-6-SWITCH_ADDED_VM: Switch 3 has been ADDED to the stack (VERSION_MISMATCH) (math-switch-1-2)

Nov 12 13:47:14: %IMAGEMGR-6-AUTO_COPY_SW_INITIATED: Auto-copy-software process initiated for switch number(s) 3

Nov 12 13:47:14: %IMAGEMGR-6-AUTO_COPY_SW:

Nov 12 13:47:14: %IMAGEMGR-6-AUTO_COPY_SW: Searching for stack member to act

Nov 12 13:47:14: %IMAGEMGR-6-AUTO_COPY_SW: as software donor...

Nov 12 13:47:14: %IMAGEMGR-6-AUTO_COPY_SW: Software was not copied

Nov 12 13:47:14: %IMAGEMGR-6-AUTO_ADVISE_SW_INITIATED: Auto-advise-software process initiated for switch number(s) 3

Nov 12 13:47:26: %IMAGEMGR-6-AUTO_ADVISE_SW:

Nov 12 13:47:26: %IMAGEMGR-6-AUTO_ADVISE_SW:

Nov 12 13:47:26: %IMAGEMGR-6-AUTO_ADVISE_SW: Systems with incompatible software have

Nov 12 13:47:26: %IMAGEMGR-6-AUTO_ADVISE_SW: been added to the stack. The storage

Nov 12 13:47:26: %IMAGEMGR-6-AUTO_ADVISE_SW: devices on all of the stack members have

Nov 12 13:47:26: %IMAGEMGR-6-AUTO_ADVISE_SW: been scanned, and the software required

Nov 12 13:47:26: %IMAGEMGR-6-AUTO_ADVISE_SW: to make all stack members compatible with

Nov 12 13:47:26: %IMAGEMGR-6-AUTO_ADVISE_SW: each other was not found. The "archive

Nov 12 13:47:26: %IMAGEMGR-6-AUTO_ADVISE_SW: download-sw" command can be used to

Nov 12 13:47:26: %IMAGEMGR-6-AUTO_ADVISE_SW: install software off of the network from

Nov 12 13:47:26: %IMAGEMGR-6-AUTO_ADVISE_SW: a tar file.

Is there any way to fix it without going there with a serial cable?

10x a lot!!

Naor

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Wed, 11/12/2008 - 04:38

If the master is the 12.2.35 version then just do a copy from switch 1 to the other incompatible members in the stack and then reload the slot . Make sure your boot statement is correct.

Joseph W. Doherty Wed, 11/12/2008 - 05:48

For a quick fix, and not 100% positive, but a reload of the stack might make the newer IOS version member the stack master and cause the other switches to run the newer IOS. (Longer term, you should get the same image on all the member switches.)

ropethic Wed, 11/12/2008 - 06:08

It has been my experience that that the master does not load the latest version of IOS. You will need to copy over the 12.2.35 to the other switches and reload. I tried the exact scenario a couple of times with IOS not getting copied over to the other switches. I had to manually tftp and chenge boot to new image.

Actions

This Discussion