DFM Learning stuck in 90%

Unanswered Question
Nov 12th, 2008

I have about 100 devices in my network and recently i added 4 more devices. but i saw that all the devices including the newly created went to learning state. and it get stuck at 90%. even a day has already passed but still the same.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Wed, 11/12/2008 - 07:48

This usually points to a daemon problem. Please post the output of the pdshow command. What version of DFM is this?

Joe Clarke Wed, 11/12/2008 - 11:00

If you're really on DFM 2.0, you need to upgrade. LMS 2.5 is over three years old, and many bugs have been fixed in the newer versions. You are most likely seeing CSCsa50868 which is fixed in DFM 2.0.1. However, I recommend you move to LMS 2.6 which currently includes DFM 2.0.12. The updates to get you to LMS 2.6 can be freely downloaded from Cisco.com. You first need to go to LMS 2.5.1, then 2.6, then you can download the individual application service packs.

LMS 2.5.1 : http://www.cisco.com/cgi-bin/tablebuild.pl/lms25

LMS 2.6 : http://www.cisco.com/cgi-bin/tablebuild.pl/lms26

The individual service packs can be obtained from Common Services > Software Center > Software Update.

Rajiv Dasmohapatra Wed, 11/12/2008 - 11:07

the bundle is LMS 2.6 already. Here is a table of installed modules.

Name Version Size Status Expiration Date

1. CM 4.0 300 Purchased Never

2. DFM 2.0 300 Purchased Never

3. IPM 2.6 300 Purchased Never

4. RME 4.0 300 Purchased Never

Joe Clarke Wed, 11/12/2008 - 11:09

Then you're not running DFM 2.0. What is the exact version of DFM you are using?

Rajiv Dasmohapatra Wed, 11/12/2008 - 11:17

the table with the versions is already provided but if it could be checked from anywhere else do let me know. regarding the bug id, it seems that after a 30 minute interval the devices move to known state. but it does not happen in this case even if a complete day has passed.

Joe Clarke Wed, 11/12/2008 - 11:18

You can get the current version from Common Services > Software Center > Software Update. If you have LMS 2.6, then you cannot be seeing this bug. However, the fix solved quite a few of the 90% hangs. Others still existed, which is why this phase of the learning process was done away with in DFM 3.0.

Joe Clarke Wed, 11/12/2008 - 11:54

Please post the DFMOGSServer.log, DFMOGSClient.log, and the NMSROOT/log/dfmLogs/TIS/TISServer.log.

Joe Clarke Wed, 11/12/2008 - 18:37

It looks like there is a group problem. Try running the script NMSROOT/bin/perl NMSROOT/MDC/tomcat/webapps/triveni/WEB-INF/classes/rmkilnerogstable.pl. Then restart Daemon Manager. This should clear up the grouping issue.

Joe Clarke Mon, 11/17/2008 - 17:49

It looks like you have more OGS problems that just DFM. I recommend you open a TAC service request so they can walk you through cleaning up your OGS database tables.

Actions

This Discussion