QoS for VoIP

Unanswered Question
Nov 12th, 2008

Guys, How are you?

I have two routers that are configured to support the VoIP service.

The VoIP calls are working, but sometimes I'm facing the quality problem, same with QoS applyed. I don't understand why this happen!

I think that with configurations, the voice traffic was priority over others traffics.

Should somebody help me?

I will go to post the configuration below

END A

class-map match-any gold

match ip rtp 16384 16383

match ip dscp ef

match ip precedence 5

class-map match-any silver

match access-group name sinalizacao_voz

!

policy-map 1M_8ch

class gold

priority 120

set ip dscp ef

class silver

set ip dscp af31

bandwidth 8

class class-default

fair-queue

random-detect

set ip dscp default

!

interface ATM1/0.2 point-to-point

bandwidth 1024

ip address

no ip route-cache

pvc 5/107

protocol ip

vbr-nrt 1242 1242

encapsulation aal5autoppp Virtual-Template102

!

interface Virtual-Template102

bandwidth 1024

ip unnumbered ATM1/0.2

ip tcp header-compression iphc-format

ppp multilink

ppp multilink fragment delay 10

ppp multilink interleave

service-policy output 1M_8ch

ip rtp header-compression iphc-format

!

ip access-list extended sinalizacao_voz

permit tcp any range 1719 1720 any

permit tcp any any range 1719 1720

permit tcp any any range 11000 11999

permit tcp any range 11000 11999 any

permit tcp any any range 2000 2002

permit tcp any range 2000 2002 any

permit tcp any any range 8001 8002

permit tcp any range 8001 8002 any

-----------------

END B

class-map match-any gold

match ip rtp 16384 16383

match ip precedence 5

match ip dscp ef

class-map match-any silver

match access-group name sinalizacao_voz

class-map match-any video

match access-group name video_conf

!

policy-map 1M_8ch

class gold

priority 120

set ip dscp ef

class silver

set ip dscp af31

bandwidth 8

class class-default

fair-queue

random-detect

set ip dscp default

policy-map 512k_8ch

class gold

priority 100

set ip dscp ef

class silver

set ip dscp af31

bandwidth 8

class class-default

fair-queue

random-detect

set ip dscp default

!

interface Serial0/1.1 point-to-point

bandwidth 1024

ip address

no cdp enable

frame-relay interface-dlci 21 ppp Virtual-Template1

class 1M

!

interface Virtual-Template1

bandwidth 1024

ip unnumbered Serial0/1.1

ip tcp header-compression iphc-format

ppp multilink

ppp multilink fragment delay 10

ppp multilink interleave

service-policy output 1M_8ch

ip rtp header-compression iphc-format

!

ip access-list extended sinalizacao_voz

permit tcp any range 1719 1720 any

permit tcp any any range 1719 1720

permit tcp any any range 11000 11999

permit tcp any range 11000 11999 any

permit tcp any any range 2000 2002

permit tcp any range 2000 2002 any

permit tcp any any range 8001 8002

permit tcp any range 8001 8002 any

Note: The link was checked and I looked okay it.

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
smahbub Tue, 11/18/2008 - 09:26

The primary goal of Quality of Service (QoS) is to make network service better and more predictable by providing dedicated bandwidth, controlled jitter and latency, and improved loss characteristics. QoS achieves these goals by providing tools for managing network congestion, shaping network traffic, using expensive wide-area links more efficiently, and setting traffic policies across the network.

Troubleshooting Quality of Service for VoIP:

http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/voice_troubleshooting/old/vts_qos.html

ayo.monehin Wed, 11/26/2008 - 04:58

Since your voice is travelling over the WAN, I was just wondering if you've got some sort of agreement with your service provider.

You can mark your traffic all you like, but if your SP aren't in synch with you then you might run into trouble.

Another thing worth mentioning is the fact that if you let your traffic "burst" above the agreed rate, your traffic (voice and data) is likely do be dropped sometimes regardless of the QoS marking because of the discard eligibility.

I would suggest you explore using Traffic Shaping.

Actions

This Discussion