How to get DEVICENAME parameter in CME

Unanswered Question
Nov 12th, 2008
User Badges:

Hi,


I am trying to get de #DEVICENAME# parameter using a url like this:

http://10.0.0.1/service.php?device=#DEVICENAME#

but doesnt work.

I know that this work fine in callmanager full, but does it work in callmanager express ?

I am using Unified Communications Manager Express 7.0


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
tstanik Tue, 11/18/2008 - 09:33
User Badges:
  • Bronze, 100 points or more

Use this command to verify which phone firmware is installed on a particular ephone. The DeviceName includes the MAC address for the IP phone.


Router# show ephone phone-load



toshiosakata Tue, 11/18/2008 - 09:52
User Badges:

hi tstanik,


Thank you for your reply.

Let me explain better:


I created a XML service and the url is

http://10.0.0.10/service.php?device=#DEVICENAME#

So, when I access this service through the ip phone (7960) I expect to get it devicename.

I have tested this in the callmanager 5.0 and works. But in the callmanager express doesnt work.

I need to identify who is the device that is accessing the service.


Thanks

stephan.steiner Wed, 11/19/2008 - 02:26
User Badges:
  • Silver, 250 points or more

Have you checked what happens if you add a regular service url to the phone on the cme and then have the phone make that call.. do you get any query string or nothing at all?

Nicholas Matthews Fri, 12/12/2008 - 18:24
User Badges:
  • Red, 2250 points or more

A little late, but thought you should know:


I just filed/resolved a bug with this. You can track it via CSCsv95576


It should be fixed in 12.4(22)T1 and 12.4(20)T2

Actions

This Discussion