Voicemail not being delivered to some Subscribers

Unanswered Question
Nov 12th, 2008
User Badges:
  • Silver, 250 points or more

Hi,

I have some users, including me, that do not recieve their voicemail, mainly from external users but some subscribers (including me dont get internal either). I can see all the messages stored on the \CommServer\UnityMTA folder.

Error messages in the Event monitor and being deliverd to me from the Event Monitoring Service are CiscoUnity_UMR Evint ID 137 and 134 also get CiscoUnity_MALEx Event ID 30012.

I get a few more but these are the most common. I have ran the permssion wizard report and it comes back clean, no failures

I have check the help guides, the Unity Error message finder and have restarted the AvUMRSyncSvr service with the CSA enabled and disabled. But the messages dot get sent.

I though it might be a permssions issue but this is happeneing to about 40 subscribers (including me :-( . I will reboot the server first tonight by stop/start Unity if that does not work I will reboot the server itself. After that I have ran out of options.

Anybody seen or had this issue. Unity UM 5.0.1. Got me a bit baffled


Thanks

Paul

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (1 ratings)
Loading.
Tommer Catlin Wed, 11/12/2008 - 08:50
User Badges:
  • Green, 3000 points or more

Are they on a new mailstore on the Exchange server? Possibly you created a new mailstore, moved those users to it in Exchange and Unity is unaware of the new store.


re-run the MailStore wizard from add/remove programs. It will start and stop your Unity services.

bigcappa1 Wed, 11/12/2008 - 10:14
User Badges:
  • Silver, 250 points or more

Tommer,

We have not added anew mailstore. It ahppened occasionally but then has happened constantly for about a month. Will restart the server and see how that sorts the issue


Let you know

Paul

bigcappa1 Thu, 11/13/2008 - 01:00
User Badges:
  • Silver, 250 points or more

Ok restarted Unity no joy, left it five mins restarted UMR service, still no joy


Restarted server, again no change again waited 5 mins the restarted UMR service.

The only thing I have not done yet is rerun the permissions wizard, though running it in report mode comes back clean.

This is a strange one


Paul

Tommer Catlin Thu, 11/13/2008 - 08:08
User Badges:
  • Green, 3000 points or more

Have you re-ran the Message Store Wizard from Add/Remove programs on the Unity box. Run this at the Console.


Also, do a DCGC reconnect. make sure everything is sysced up in your AD to your Unity server. If there is an issue with DCGC connect, it will flag it in the Windows Event Viewer Applications.

bigcappa1 Thu, 11/13/2008 - 10:22
User Badges:
  • Silver, 250 points or more

Going to run the PW tommorrow, to run the MSCW do i need to run it fromthe DVD. I now it is aprt ofthe install process but never ran it aprat from at the install

I dont esee any DCGC connect issues in the event viewer all the events seem UMR based


cheers

Paul

Tommer Catlin Thu, 11/13/2008 - 10:25
User Badges:
  • Green, 3000 points or more

On the Unity server.

Start settings Control panel

Add/Remove Programs


It is in the list. Re-run (it will not uninstall or re-install)



bigcappa1 Thu, 11/20/2008 - 09:14
User Badges:
  • Silver, 250 points or more

Ok have done the PW and the MSCW. Restarted the UMR service (lots of times). Had a DC error so corrected that manually with the DCDG utility and still nothing. After we ram the PW some of the users starting getting trapped internally left voicemail but external still was an issue.

So the scenario is some users cannot get any internal or external voicemail. Some users can only get internal voicmeail and a majority of users dont have an issue. Got me stummped now.

Anyone else got ideas. Took a while to run all the wizards as we need to get out AD team and messaging team involved


cheers

Paul

Tommer Catlin Thu, 11/20/2008 - 09:27
User Badges:
  • Green, 3000 points or more

Do you have any errors in your Unity server in Application or system?


Also, for the subscribers that are not working, if you toggle an old voice mail message from read to unread, does the MWI light come on? If it does, Unity does have access to the subscriber account and is reading Exchange correctly. If the light does not toggle, then you still have a permissions issues on the AD account. (typically)


For subscribers not getting internally or externally voicemail (which sounds like no voicemails to me) are the voicemails sitting in the MTA folder on Unity waiting to be delivered or are they marked in the failed folder?

bigcappa1 Mon, 11/24/2008 - 05:10
User Badges:
  • Silver, 250 points or more

The errors that I get in the Event log are CiscoUnity_MALEx ID 30007 and 30012 both to do with the CsBMsgConnector connecting properly via MAPI. I dont think this is the main issue as the connector is in relation to broadcasting is it not. The message guys did delete the account connected to this but have since enabled it again.

The other error is CiscoUnity_UMR ID 134. This is coming up as I am getting a few unaddressed messages and I dont have anything set up in the PUBLIC DL to forward them onto someone. Not worried about that yet.

So I would like to tidy the first error up but as I say dont think this causes the issue of some subscribers not getting VM where a majority of other do.

Yes all the VM sit in the MTA folder so I can jump on and attach the wav file to an email but that is time comsuming. I have restarted the MTAsynch service in the services pretty much now after I try something. And still no joy. I suppose if it was all users we would be ok, but the fact it is just some users makes it really difficult to solve.


Many thanks

Paul

Tommer Catlin Mon, 11/24/2008 - 07:39
User Badges:
  • Green, 3000 points or more

I think you have a corrupted MAPI profile. I would probably get TAC involved to fix the MAPI. Basically need to delete the MAPI and re-create it.

Tray Stoutmeyer Mon, 11/24/2008 - 08:44
User Badges:
  • Cisco Employee,

If you want to delete/recreate mapi then go to the registry and search for Unity System Profile. The second one you find is the one that contains numerous keys with random code on them. Those are the profiles. Delete the Unity System Profile there and reboot.


Tray


bigcappa1 Tue, 11/25/2008 - 03:51
User Badges:
  • Silver, 250 points or more

Tray,

Great, thanks for the feedback on this. Had look but i thinkas they deleted the usbms account and mailbox that I need to get this correctected as the usbms account was not in the Unity System Profile. So will look at this.

I dont think this is causing the main issue of some users not egetting their voicemail. Do you have more details on the purpose of the usbms account ata all


thanks

Paul

Tommer Catlin Tue, 11/25/2008 - 07:26
User Badges:
  • Green, 3000 points or more

When I see MAPI and AD admins who delete Unity accounts by mistake, it seems to be a slow house of cards. You will get one or two subscribers not working, then all of sudden, nobody will work.

bigcappa1 Tue, 11/25/2008 - 07:41
User Badges:
  • Silver, 250 points or more

That brings a smile to my face, I know Unity can be very tricky, and sometimes even blowing on ti causes problems. Thanks for the warning time for TAC I think

Tommer Catlin Tue, 11/25/2008 - 07:52
User Badges:
  • Green, 3000 points or more

The last major issue with Unity I had with TAC turned out to be a corrupted MAPI profile on Unity. We spent hours! They finally figured it out that somehow, Unity corrupted the MAPI profile or the Message Store Wizard broke it. Unity was still running fine for some Subscribers, but then would stop... then all of sudden, all subscribers were not get VM and MWI. But Unity take messages, etc.



bigcappa1 Mon, 12/15/2008 - 07:52
User Badges:
  • Silver, 250 points or more

Ok this one gets better now. After installing another instance on Unity at another location around 45 mins after the PW was run on a completely different OU the voicemail started to get kicked out of the UMR folder. I recieved about 6 from the last few weeks, the only problem with this now was is that the voicemail is now being sent to the mailbox but Unity has no knowledge it exists, it does not give any MWI or whn you go into the mailbox there are no messages, yet you can see the unopened message in your inbox. Has anyone seen this?

Bradford Magnani Mon, 12/15/2008 - 07:59
User Badges:
  • Cisco Employee,

Double check that nothing is changing the message class to anything other than IPM.Note.Voice.Unity. If so, Unity won't recognize it.


Brad

bigcappa1 Mon, 12/15/2008 - 08:02
User Badges:
  • Silver, 250 points or more

Brad,

Sorry where would I check this to confirm


thanks

Paul

Bradford Magnani Mon, 12/15/2008 - 08:07
User Badges:
  • Cisco Employee,

run the following from command prompt:


X:\CommServer\TechTools\DohPropTest.exe -a


Click OK, Ignore


Select the user you want from MailUsers category once it loads. Then click "Get User's Mailbox" then select the message in the left pane and then scroll down to the Object Property AVP_MESSAGE_CLASS. This should be IPM.Note.Voice.Unity


Brad

bigcappa1 Mon, 12/15/2008 - 08:26
User Badges:
  • Silver, 250 points or more

Brad,

Thanks for that and I can confirm it is IPM.Note.Voice.Unity. Will see what else I can find that causes this. Personally I think the Unity is getting sick.


Thanks

Paul

stevenle Tue, 01/06/2009 - 13:25
User Badges:

I do know the quick fix for this. But I'm also looking for a permanent fix. this happens occasionally and although we can fix it quickly we still have not found the cause and eliminated it. Two TAC cases and still nothing. I've been scouring through the forums to see if we can find a similar issue with a permanent fix.

Actions

This Discussion