MPLS TE tunnel not coming up - RSVP issue?

Answered Question
Nov 12th, 2008
User Badges:

Hello,


I have two routers R2 and R5 back to back and I am trying to create an MPLS TE tunnel between them. R2 already has one tunnel up and running to another router R1.


I think my issue is that no RSVP traffic is being sent by R2 or R5. Here is my interface config on R5 and some show commands:


R5#show run int s2/0

Building configuration...


Current configuration : 143 bytes

!

interface Serial2/0

ip address 192.168.25.5 255.255.255.0

mpls traffic-eng tunnels

fair-queue 64 256 32

ip rsvp bandwidth 1000 1000

end


R5#show ip int brief s2/0

Interface IP-Address OK? Method Status Protocol

Serial2/0 192.168.25.5 YES NVRAM up up


R5#show ip rsvp counters in s2/0

Serial2/0 Recv Xmit Recv Xmit

Path 0 0 Resv 0 0

PathError 0 0 ResvError 0 0

PathTear 0 0 ResvTear 0 0

ResvConfirm 0 0 ResvTearConfirm 0 0

UnknownMsg 0 0 Errors 0 0

R5#


I have mpls traffic-eng tunnels on all routers and interfaces. Here here is my tunnel config on R5 towards R2:


R5#show run int tun 2

Building configuration...


Current configuration : 174 bytes

!

interface Tunnel2

ip unnumbered Loopback0

tag-switching ip

tunnel destination 10.0.0.2

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 dynamic

end


I also am learning all addresses via OSPF so R5 does have a route (and can ping) 10.0.0.2 (R2's loopback)


Any ideas where this is failing? Why isn't RSVP sending packets?


Thanks,

Correct Answer by Harold Ritter about 8 years 6 months ago

Bryan,


Please enable "ip cef" on R5 and everything should start working.


Regards

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Giuseppe Larosa Wed, 11/12/2008 - 09:37
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Bryan,


interface Tunnel2

ip unnumbered Loopback0

>>tag-switching ip


this doesn't look like correct you need to put mpls traffic-engineering commands


look at this example


http://www.cisco.com/en/US/tech/tk436/tk428/technologies_configuration_example09186a0080093fcb.shtml#configs


you need

tunnel mode mpls traffic-eng


try to remove

tag-switching ip


and each router has to declare its loopback as its mpls traffic-eng router-id inside the OSPF process


Hope to help

Giuseppe




dodgerfan78 Wed, 11/12/2008 - 09:53
User Badges:

Thank you Guiseppe. I have removed that command and I already do have the tunnel mode set to traffic-eng as you can see in my previous post. Also, in my ospf config I have:


mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0


Thanks for your reply...I am totally stimped on this.




Harold Ritter Wed, 11/12/2008 - 10:04
User Badges:
  • Cisco Employee,

Can you post the output of "show mpls traff tunn tunn2".


Regards

dodgerfan78 Wed, 11/12/2008 - 10:10
User Badges:

Sure.


R5#show mpls traffic-eng tunnels tunnel 2


Name: R5_t2 (Tunnel2) Destination: 10.0.0.2

Status:

Admin: up Oper: down Path: not valid Signalling: Down

path option 1, type dynamic


Config Parameters:

Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF

Metric Type: TE (default)

AutoRoute: disabled LockDown: disabled Loadshare: 0 bw-based

auto-bw: disabled(0/200) 0 Bandwidth Requested: 0


Shortest Unconstrained Path Info:

Path Weight: UNKNOWN

Explicit Route: UNKNOWN

History:

Tunnel:

Time since created: 1 minutes, 41 seconds

Path Option 1:

Last Error: PCALC:: No path to destination, 10.0.0.2

R5#


But R5 does have a path to 10.0.0.2:


R5#ping 10.0.0.2


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/33/36 ms

R5#


In fact, R5 even has the opaque-lsa for 10.0.0.2:


R5#show ip ospf database opaque-area adv-router 10.0.0.2


OSPF Router with ID (10.0.0.5) (Process ID 1)


Type-10 Opaque Link Area Link States (Area 0)


LS age: 184

Options: (No TOS-capability, DC)

LS Type: Opaque Area Link

Link State ID: 1.0.0.0

Opaque Type: 1

Opaque ID: 0

Advertising Router: 10.0.0.2

LS Seq Number: 80000001

Checksum: 0x46F1

Length: 132

Fragment number : 0


MPLS TE router ID : 10.0.0.2


Link connected to Point-to-Point network

Link ID : 10.0.0.1

Interface Address : 192.168.12.2

Neighbor Address : 192.168.12.1

Admin Metric : 64

Maximum bandwidth : 193000

Maximum reservable bandwidth : 187500

Number of Priority : 8

Priority 0 : 187500 Priority 1 : 187500

Priority 2 : 187500 Priority 3 : 187500

Priority 4 : 187500 Priority 5 : 187500

Priority 6 : 187500 Priority 7 : 187500

Affinity Bit : 0x0


Number of Links : 1


LS age: 182

Options: (No TOS-capability, DC)

LS Type: Opaque Area Link

Link State ID: 1.0.0.1

Opaque Type: 1

Opaque ID: 1

Advertising Router: 10.0.0.2

LS Seq Number: 80000001

Checksum: 0xFEB

Length: 124

Fragment number : 1


Link connected to Point-to-Point network

Link ID : 10.0.0.5

Interface Address : 192.168.25.2

Neighbor Address : 192.168.25.5

Admin Metric : 5

Maximum bandwidth : 2500000

Maximum reservable bandwidth : 125000

Number of Priority : 8

Priority 0 : 125000 Priority 1 : 125000

Priority 2 : 125000 Priority 3 : 125000

Priority 4 : 125000 Priority 5 : 125000

Priority 6 : 125000 Priority 7 : 125000

Affinity Bit : 0x0


Number of Links : 1


R5#


192.168.12.x is the net between R1 and R2 (there is a tunnel there and it is up/up.


192.168.25.x is between R2 and R5.


thanks,



dodgerfan78 Wed, 11/12/2008 - 10:52
User Badges:

Here you go. I have made some changes since then but nothing major. Just adding interfaces under the OSPF MPLS traffic-eng to see if that will work. Also, there is a couple tunnels you see that I have not started to work on yet. Tunnel 5 on R2 points to R5. Tunnel 2 on R5 points to R2.


=====================================

R2:


R2# show run

Building configuration...


Current configuration : 1965 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R2

!

logging buffered 16384 debugging

!

!

!

ip subnet-zero

ip cef

!

!

no ip domain-lookup

!

mpls label protocol ldp

mpls traffic-eng tunnels

tag-switching tdp router-id Loopback0

!

!

!

!

!

!

!

!

!

!

interface Loopback0

ip address 10.0.0.2 255.255.255.255

!

interface Tunnel1

ip unnumbered Loopback0

tunnel destination 10.0.0.1

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 dynamic

!

interface Tunnel3

ip unnumbered Loopback0

tag-switching ip

tunnel destination 10.0.0.3

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 dynamic

!

interface Tunnel5

ip unnumbered Loopback0

tunnel destination 10.0.0.5

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 dynamic

!

interface FastEthernet1/0

ip address 205.127.233.242 255.255.254.0

speed 100

full-duplex

!

interface Serial2/0

ip address 192.168.12.2 255.255.255.0

mpls traffic-eng tunnels

fair-queue 64 256 37

ip rsvp bandwidth 1500 1500

!

interface Serial2/1

bandwidth 20000

ip address 192.168.25.2 255.255.255.0

mpls traffic-eng tunnels

fair-queue 64 256 37

ip rsvp bandwidth 1000 1000

!

interface Serial2/2

no ip address

shutdown

!

interface Serial2/3

no ip address

shutdown

!

router ospf 1

router-id 10.0.0.2

log-adjacency-changes

network 10.0.0.2 0.0.0.0 area 0

network 192.168.12.0 0.0.0.255 area 0

network 192.168.23.0 0.0.0.255 area 0

network 192.168.25.0 0.0.0.255 area 0

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

mpls traffic-eng interface Serial2/0 area 0

mpls traffic-eng interface Serial2/1 area 0

mpls traffic-eng interface Loopback0 area 0

!

ip classless

ip http server

ip pim bidir-enable

!

!

!

call rsvp-sync

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

login

!

!

end


R2#


====================================


R5:


R5#show run

Building configuration...


Current configuration : 1492 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname R5

!

logging buffered 16384 debugging

!

!

!

ip subnet-zero

!

!

no ip domain-lookup

!

mpls label protocol ldp

mpls traffic-eng tunnels

tag-switching tdp router-id Loopback0

!

!

!

!

!

!

!

!

!

!

interface Loopback0

ip address 10.0.0.5 255.255.255.255

!

interface Tunnel2

ip unnumbered Loopback0

tunnel destination 10.0.0.2

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng path-option 1 dynamic

!

interface Serial2/0

ip address 192.168.25.5 255.255.255.0

mpls traffic-eng tunnels

fair-queue 64 256 32

ip rsvp bandwidth 1000 1000

!

interface Serial2/1

ip address 192.168.45.5 255.255.255.0

shutdown

mpls traffic-eng tunnels

fair-queue 64 256 37

ip rsvp bandwidth 1000 1000

!

interface Serial2/2

no ip address

shutdown

fair-queue 64 256 37

ip rsvp bandwidth 10000 10000

!

interface Serial2/3

no ip address

shutdown

!

router ospf 1

router-id 10.0.0.5

log-adjacency-changes

network 10.0.0.5 0.0.0.0 area 0

network 192.168.25.0 0.0.0.255 area 0

network 192.168.45.0 0.0.0.255 area 0

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

mpls traffic-eng interface Serial2/0 area 0

mpls traffic-eng interface Loopback0 area 0

!

ip classless

ip http server

ip pim bidir-enable

!

!

!

call rsvp-sync

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

!

!

!

end


R5#


======================================


thanks


Correct Answer
Harold Ritter Wed, 11/12/2008 - 11:41
User Badges:
  • Cisco Employee,

Bryan,


Please enable "ip cef" on R5 and everything should start working.


Regards

tarjbains Thu, 12/11/2008 - 15:49
User Badges:

hello my freind i dont know that much about TE but in ur tunnel interface commands u have nt put auto route announce command---> tunnel mpls traffic-eng autoroute announce

interface Tunnel1

ip unnumbered Loopback1

tunnel destination 192.168.1.3

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute announce (this above command is very important)

tunnel mpls traffic-eng priority 1 1

tunnel mpls traffic-eng bandwidth 300

tunnel mpls traffic-eng path-option 10 dynamic

!

cus ur data cant route if it doesnt know the route. might be it can problem--


static

policy base

auto route


Harold Ritter Fri, 12/12/2008 - 08:32
User Badges:
  • Cisco Employee,

Tarj,


Autoroute announce is not the only way to push traffic through the tunnel. You can also use a static route pointing with the tunnel as the next hop interface or use PBR to set the tunnel as the next hop interface.


Regards

tarjbains Mon, 12/15/2008 - 13:54
User Badges:

yea m8 ur right i know that but if u look in that guy router's sh run configuration he has not mention any autoroute or static route or even PBR in his configuration. in 12 nov post b dodger sh run.

tarjbains Mon, 12/15/2008 - 13:57
User Badges:

(Here you go. I have made some changes since 12 nov)check that one post above there is full router SH Run n u cant find autoroute or static route command in tunnels. so i thought might be thats problem


Regards

Harold Ritter Mon, 12/15/2008 - 14:18
User Badges:
  • Cisco Employee,

Tarj,


This thread has been solved on Nov 12th. "ip cef" was missing from the config.


Regards

tarjbains Mon, 12/15/2008 - 15:40
User Badges:

thanks m8 i have one problem now m tryin to use mpls auto bandwidth adjustment command but problem is when i put two commands togather one disappear from list

1. tunnel mpls traffic-eng auto-bw frequency 600

2. tunnel mpls traffic-eng auto-bw max-bw 60 min-bw 30


why according to cisco lab i can put two commands togather if i remove one then other one comes up. but problem is i want to decrease the time of readjust ment by default it is 24 hour 86400 sec. i put 300 sec n set bandwidth min max they both r oppsite. m using 3660 router on dayangen.

configuration

----------------------------

interface Tunnel1

ip unnumbered Loopback9

tunnel destination 192.168.1.5

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute announce

tunnel mpls traffic-eng priority 1 1

tunnel mpls traffic-eng bandwidth 50

tunnel mpls traffic-eng path-option 10 dynamic

tunnel mpls traffic-eng auto-bw max-bw 60 min-bw 30

no routing dynamic

end

plz reply soon


i put both commands it appear togather in configuration sh run. but when frequency time 300 finish then bandwidth become 0 cus m using danagen so there is no traffic load. but it should stay to min bandwidth.

tarjbains Mon, 12/15/2008 - 15:46
User Badges:

u can see tunnel1 config that in both configuration two of command r not comming up same


interface Tunnel1

ip unnumbered Loopback9

tunnel destination 192.168.1.5

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute announce

tunnel mpls traffic-eng priority 1 1

tunnel mpls traffic-eng bandwidth 50

tunnel mpls traffic-eng path-option 10 dynamic

>>> tunnel mpls traffic-eng auto-bw frequency 600

no routing dynamic

end


i want to set frequency time 10 min and tunnel max n min bandwidth that should change according to tunnel adjustmen after frequency but these both command not coming up at same time. i have done sumthin wrong?

tarjbains Thu, 12/11/2008 - 15:52
User Badges:

hello my freind i dont know that much about TE but in ur tunnel interface commands u have nt put auto route announce command---> tunnel mpls traffic-eng autoroute announce


interface Tunnel1

ip unnumbered Loopback1

tunnel destination 192.168.1.3

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute announce <--this command is very important)

tunnel mpls traffic-eng priority 1 1

tunnel mpls traffic-eng bandwidth 300

tunnel mpls traffic-eng path-option 10 dynamic

!

cus ur data cant route if it doesnt know the route. might be it can problem--


static

policy base

auto route

Actions

This Discussion