ASA 5510 LDAP Authentication and Server 2008

Unanswered Question
Nov 12th, 2008

Helo all,

I have allways configured and run LDAP Server Groups authenticating to Active Directory Domain Controllers using LDAP, never an issue, until I hit a Domain Controller running on a Windows Server 2008. I have been unable to authenticate with the common setting with an ASA5510 running 8.0.1. It definitely looks like AD on 2008 might have some issues with this, does anyone have any input on this?

Thanks in advanced

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
hadbou Tue, 11/18/2008 - 15:00

I think that LDAP works with ACTIVE DIRECTORY on Microsoft server 2008.Try configuring the LDAP server again as any misconfiguration may have caysed the problem.Authentication works fine with Microsoft server 2003.It will be easy to find the cause of the issue if the exact error messgae is provided.

pbanzato1 Tue, 11/18/2008 - 15:24

Thanks for the reply. I cant test now, I will do it tomorrow, but the message was something like "Failed to authenticate, the server was removed..."

I never had a problem with server 2003, but this 2008 is a no go after reconfiguring several times using different accounts and LDAP strings.

Most important, I found a blog from a guy who had everything working on 2003, then he upgraded to 2008 and it stoped working.

srue Tue, 11/18/2008 - 18:21

have you tried "ldap-over-ssl enable" under the aaa-server config?

if the server is a global catalog server, try using that port:

server-port 3268

let us know if you figure it out.


Azhar Munawar Mon, 02/13/2012 - 20:59


Did it work?

I am going to configure my firewall with LDAP with windows 2008 i just want to know will it work or not?




This Discussion